Perl script doen't work for a specific user [SOLVED]

Patrick Nelson pnelson at
Thu Jun 24 15:56:19 UTC 2004

On Thu, 2004-06-24 at 06:46, Scot L. Harris wrote:
> On Thu, 2004-06-24 at 04:43, Patrick Nelson wrote:
> > FC1
> > 
> > I set up a script that calls sa-learn (from spamassassin)  on one FC1
> > system this works just fine but on another system is errors.  Here is
> > the basic call:
> > 
> > su filter -c "sa-learn --spam <mailbox>"
> > 
> > The systems are identical except for something that fails on the one
> > system.  If I log into the system as filter like:
> > 
> > su -l filter
> > 
> > and then try and just run sa-learn I get a bunch of errors like:
> > 
> > Can't locate Mail/SpamAssassin/ in @INC (@INC contains:
> > This seems to be so for all users but root.  What would be controlling
> > this?  Any ideas would help...
> > 
> The first few things to verify is that the packages for spamassassin are
> installed correctly.  Check versions as well.
> The message above seems to indicate a possible path or permissions
> problem.
> Since you have one system that works and one that doesn't then you can
> compare both setups to see what is different.  Start by looking for the
> file.  Here it is owned by root and has 644 permissions.

Wow, you were right.  I never thought of looking at the permissions (OMG
I've been bit by that before).  These were two systems that were built
side by side with the standard rpms...  Yet you were right I walked
through the spamassassin perl and lib dirs and all the sub-dir were in
fact 700.  Arg, but I changed them and it worked...  Thanks.

More information about the fedora-list mailing list