[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

FC1 install fails to boot



I am trying to install FC1 (sic) on a new system that came pre-installed with XP
using month old iso cdroms I previously used successfully to install FC1
on an AMD xp2600 system.  The new system will be an audio workstation and I'd prefer,
for now, to run a patched 2.4 kernel until a 2.6 kernel with low latency patches
and other performance tweaks becomes available and tuned.
The P4 FC1 install seems to proceed without a hitch, but the system hangs upon
first boot with a blank screen after loading the kernel modules (after
   Enabling swap space   OK )
and never gets to the Welcome screen.

The system: -------------------------------
P4  3GHz 800 FSB,  Gigabyte 8i K 1100, Intel 875P chipset, 1 GB dual chan. Samsung DDR,
Matrox Millenium G550
Disks: Seagate 120 GB  ST3120022A (system disk for both linux and XP)
 Western Digital  Raptor 740GD SATA 74 GB (to be used only as a sound disk)
 Intel 82801EB ultra ata controller, 82801ER raid controller, ICH5R sata controller
  Plextor dvdr px-708a
 Floppy drive (came DOA, so unavailable until I receive the replacement) 
Texas Instruments OHCI i333 1394 host controller
(Also: Intel pro/100 ve network adapter, M-Audio Delta 1010, Planar 1910M,
Logitech optical corded kb & cordless wheel mouse )
------------------
Win xp still runs fine. I cannot boot into linux single mode.
In rescue mode, all my linux and xp file systems mount correctly.  The swap
partition is 900 MB.
Looking at install.log.syslog, install.log, anaconda.cfg, dmesg and other
config and log files no obvious problems jump out. The only error message I see
is in /var/boot.log:
 Window Manager warning: Failed to open connection to a session manager ... SESSION_MANAGER
  environment variable not defined.

I tried re-installing with the firewire controller disabled in the bios and (for
good measure, disconnecting the firewire cable from the motherboard.) Same result.

I thought that the problem might be the sata controller, but ata_piix seems to load properly
and my understanding (http://www.linuxmafia.com/faq/hardware/sata.html) is
that from 2.4.22 on ata_piix is a part of the libata driver set.
I've seen the i875 chipset listed as fully compatible with newer kernels.
In googling the Gigabyte 8ik 1000 mobo I came across 2 references to its use
on linux systems.

I'm stumped and at this point and for the moment don't even care about tuned performance.
Right now I just want to get ANY linux distro installed on this system and get moving.
Now that the dust seems to have settled on how to avoid the FC2 dual boot MBR
problem (so that I don't have to worry about winding up with neither a usuable
linux nor xp system with which to troubleshoot this problem)
is it likely that that the newer FC2 build would install succesfully
where FC1 fails?  Should I try a newer 2.4 kernel?

Thanks in advance for any help or suggestions. 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]