[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: usb storage and FC2



On Fri, 2004-06-04 at 12:17, Alexander Apprich wrote:
> >>>I recently upgraded to FC2, and i can't use usb memory sticks. Nothing
> >>>happens when i plug the stick in. No usb-storage module loaded,
> >>>/var/log/messages says:
> >>>
> >>>
> >>>Jun  3 16:48:23 brunettie kernel: usb 3-2: new full speed USB device
> >>>using address 2
> >>>Jun  3 16:48:28 brunettie kernel: usb 3-2: control timeout on ep0out
> >>>Jun  3 16:48:28 brunettie kernel: uhci_hcd 0000:00:1d.2: Unlink after
> >>>no-IRQ?  Different ACPI or APIC settings may help.
> >>>
> >>>I really don't get it. What should i do? Actually it looks like
> >>>usb-storage wasn't even compiled as a module...but it looks too strange
> >>>to me.
> >>>
> >>>Thanks 
> >>
> >>Have you tried mounting the device?
> >>
> >>mount -t auto /dev/sda1 /mnt
> > 
> > No way. I can't mount something without, at least, having kernel mode
> > usb-storage properly insmod'ed. And what i was saying a few lines up, is
> > that apparently usb-storage is missing from my machine - though i
> > upgraded from FC1 to FC2 by iso images.
> > 
> > Somebody told me that this thing of memeory stick not being mounted was
> > something known to happen with FC2. Maybe they were wrong. 
> > 
> > My point now is: i don't have usb-storage on my system - is this normal
> > for a normal FC2 upgrade? How can i do to fix it? Brand new kernel or
> > just compiling some new modules? As to both chances, a bit of help is
> > needed. I never compiled a 2.6.
>
> What does
> 
>      locate usb-storage
> 
> or (as root)
> 
>      modprobe usb-storage
> 
> Say?

I guess you may be right. usb-storage is indeed present, but not loaded
automatically. I can insert module usb-storage, and it gets properly (i
presume) 'linked' to scsi_mod. However, if i try to mount /dev/sda1, i
still get errors: it says it is not a valid block device (which is fals,
it works perfectly on FC1 and other linux systems).

> AFAIK there was a bug with usb storage in 2.6.5. An upgrade of your
> kernel might help.

That is exactly what i am running. So, i should compile a new kernel?
Mmmmm...this is not really on the idea of a desktop distro, isn't it?
But i wonder if i am the only one experiencing such a problem. I mean,
memory sticks are quite normal, aren't they? Are you all using kernel
2.6.5.1-358 wihtout problems?

Thanks

E.






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]