[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Flickering screen with FC1 and Dell 8600



On Sat, 2004-05-15 at 03:59, Chris Jones wrote:
> Hi,
> 
> I have a inspiron 8600 laptop with a WUXGA 1920x1200 screen and a NVIDIA 
> Geforce4go 5650 video card with the NVIDIA 5336 drivers installed. I am 
> trying to get the graphics to work properly with Fedora Core 1.
> After searching through the wbe etc. I have found a set of options which 
> seem to work but the screen suffers from occasion flickering.
> 
> My XF86Config and Xfree.0.log files are
> http://www.hep.phy.cam.ac.uk/~jonesc/8600/XF86Config
> and
> http://www.hep.phy.cam.ac.uk/~jonesc/8600/XFree86.0.log
> 
> This is my first experience of installing linux on a laptop, so please 
> forgive any mistakes or newbie-status.
> My questions are
> 
> Have I configured X correctly ? I found a number of ModeLines which give 
> different refresh rates i.e.
> 
>          #1920x1200 @ 52Hz
>          #ModeLine    "1920x1200" 162        1920 1984 2176 2480 1200 
> 1201 1204 1250 +hsync +vsync
>          #1920x1200 @ 60Hz
>          Modeline     "1920x1200" 161.750000 1920 2020 2052 2184 1200 
> 1202 1208 1235 -HSync -VSync
> 
> Is one better than the other ? Also are these correct (again I have 
> found various versions)
> 
>          HorizSync    31.5 - 100.0
>          VertRefresh  30.0 - 90.0
> 
> Has anyone else with this hardware experinced flickering ? Could it it 
> something else (DPMS ?) I am running kdm desktop with KDE 3.2.2.

I have a flickering problem, Inspiron 8600, Nvidia 5650, but a step down
in screen res from your model (1680x1050). I run Gnome.

I see a regular flicker for about a second, which occurs every 7-8
minutes. This is using the 5336 driver from Nvidia. For a while I used a
packaged kernel module from livna, and didn't see the problem, but did
have other issues (kernel upgrade and it was very difficult to get the
driver working again).

Is your flicker regular like this?

My settings:

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "LCD Panel"
        UseModes     "16:10"
        HorizSync    31.5 - 90.0
        VertRefresh  59.0 - 75.0
        Option      "dpms"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "NVidia card"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Depth     16
                Modes    "1680x1050" "1400x1050" "1280x1024" "1280x960"
"1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth     24
                Modes    "1680x1050" "1400x1050" "1280x1024" "1280x960"
"1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

My modelines (yours seem to have lower refresh rates).
        Identifier     "16:10"
        ModeLine     "1680x1050" 188.1 1680 1800 1984 2288 1050 1051
1054 1096
        # 1680x1050 @ 85.00 Hz (GTF) hsync: 93.76 kHz; pclk: 214.51 MHz
        ModeLine     "1680x1050" 214.5 1680 1800 1984 2288 1050 1051
1054 1103
        # 1680x1050 @ 100.00 Hz (GTF) hsync: 111.20 kHz; pclk: 256.20
MHz
        ModeLine     "1680x1050" 256.2 1680 1808 1992 2304 1050 1051
1054 1112
        # 1920x1200 @ 75.00 Hz (GTF) hsync: 93.97 kHz; pclk: 246.59 MHz
        ModeLine     "1920x1200" 246.6 1920 2064 2272 2624 1200 1201
1204 1253
        # 1920x1200 @ 85.00 Hz (GTF) hsync: 107.10 kHz; pclk: 282.74 MHz
        ModeLine     "1920x1200" 282.7 1920 2072 2280 2640 1200 1201
1204 1260
        # 1920x1200 @ 100.00 Hz (GTF) hsync: 127.10 kHz; pclk: 337.58
MHz
        ModeLine     "1920x1200" 337.6 1920 2072 2288 2656 1200 1201
1204 1271

Hope this helps, 

Cheers, Ben





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]