[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problems getting 2 NICs to work.



I tried this and get "RTNETLINK answers: Invalid Argument". Then I tried to just manually add these routes:

ip route add 12.168.88.0 dev eth0
ip route add 204.117.218.0 dev eth1

It accepts these but can't seem to do lookups. I get a "connect: Network is unreachable" with any ping or trace attempt. I know there is something simple missing here. I'm reading this Advanced Routing HOWTO and it seems section 4.2 is exactly what I'm trying to do but I'm having a bit of trouble making sense of what commands go into what files.

++ Kevin Kimmell + kevin_AT_dynamictrend.com + Dynamic Trend, Inc. ++



Alexander Dalloz wrote:

Am Mo, den 17.05.2004 schrieb Kevin Kimmell um 17:50:



Yes, I have two full class c networks from 2 different ISPs. I am simply trying to assign one IP address from each ISP to the two NICs in these machines. When both NICs are acivated, they both show up in a cat of /proc/interrupts.



Ok, so it is the first step to get at least 1 IP from each net working in parallel. Understand that not. Just wanted to be sure.



Another observation that I've made (I'm unsure if it even means anything):

When I "ifup eth1" the default route moves from the gateway of eth0 to the gateway of eth1 and then when I ifdown eth1 the default gateway ceases to exist.

Strange things...



No, that is not strange. That is how the network scripts work. You defined the GATEWAY each in the ifcfg-ethX configurations files. As your setup is no typical one you will have to do some more handwork. At least delete the GATEWAY entries and make use of static routes. Create

/etc/sysconfig/network-scripts/route-eth0

with following content

12.168.88.12/24 via 12.168.88.254

and

/etc/sysconfig/network-scripts/route-eth1

204.117.218.12/24 via 204.117.218.254

Alexander







[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]