[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

FC2 success story



Well yesterday I decided to do a fresh FC2 install on my Dell Inspiron
300m laptop. I did a default workstation install and found it works
better than the upgrade I previously did from FC1. One thing I noticed
right away is that the yenta_socket loaded automatically vs having to
manually load it then restart the pcmcia service to be able to use my
USR wireless card. Then since I just got my Intel Pro Wireless 2100
mini-PCI card I decided to give that a try.

First I had to install the kernel-source and qt-devel packages
(kernel-source needs qt-devel) and did a "make oldconfig" then a "make
modules". Then unpack the hostap-driver source, compile and install it.
Then did the same with the ipw2100 driver and installed the firmware. I
tried loading the ipw2100 module but it just loaded but wasn't finding
the card, even lspci didn't show the card so I started searching the web
and found a page from someone with a HP Compaq laptop that got it to
work and also got his modem to work. I had previously tried to get my
modem working but without any luck. But he was using the ALSA drivers
and I thought I should give that a try so I compiled and installed the
slmodemd program from Smart Link and got the modem to work right away.
Still haven't been able to get the wireless card to work though. So
anyway it was getting late so I went to bed.

This morning I got at work early and got my laptop out and though I'd
check into the BIOS if I could find anything, the wireless was enabled
but the mini-PCI slot was disabled so I enabled it and when I booted
into FC2, kudzu found the wireless card and asked me to configure it. So
after the computer finished booting I checked if the module was loaded
and it was but still the wireless card wasn't working. Tried unloading
and loading the module by hand but I was getting errors about the driver
not finding the firmware. Since I had subscribed to the ipw2100-devel
list yesterday and got my first post this morning about someone having
the same problem with the 0.45 driver and saying it was working in 0.44
I decided to install the 0.44 driver. Loaded the module and it found the
firmware and I had wireless access with the internal wireless card in my
laptop!

Still a few things here and there that I gotta fix though but I finally
got rid of my PCMCIA wireless card which was one thing I wanted to do
for a while. The only major thing I need to get working now is ACPI but
that's gonna be a different story...

Few links of interest for people with similar laptops or even just
laptops:

ftp://ftp.smlink.com/linux/unsupported (Smart Link modem driver)
http://ipw2100.sourceforge.net (Intel Pro Wireless driver, has links for
HostAP and all needed stuff)
http://www.linuxforum.com/forums/index.php?showtopic=74608 (Instruction
for getting the ipw2100 driver to compile and load on FC2)
http://personal.eunet.fi/pp/joakim/nx7010.html (FC2 on a HP Compaq
nx7010, some useful info for Centrino based laptops)

Sorry for the long post but I just thought I'd share and let people know
there's hope for Linux on the laptop ;)

Jean-Rene Cormier




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]