[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Unable to open USB device - a second time



On Fri, 2004-10-22 at 16:45, Truls Gulbrandsen wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Paul Howarth wrote:
> 
> | Truls Gulbrandsen wrote:
> |
> |> I had no success with my original posting so I try again.
> |>
> |> Hi, I just purchased a HP pcs2175 and are trying to get it to
> |> work with my TP T23 running FC2.
> |>
> |> I succeeded in installing the driver and the printer (I think)
> |> but not the USB device.
> |>
> |> The printer configuration gives the following error message:
> |> <Unable to open USB device "usb:/dev/usb/lp0": No such device>
> |>
> |> Can someone here please guide me on how to make the USB port
> |> work?
> |
> |
> | What is in your /etc/modprobe.conf file?
> |
> | What is the output of "lsmod"?
> |
> | What messages appear in /var/log/messages when you plug in your
> | printer?
> |
> | Paul.
> |
> Mymodprobe.conf shows:
> 
> alias snd-card-0 snd-intel8x0
> install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0
> &&/usr/sbin/alsactl restore >/dev/null 2>&1 || :
> remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ;};
> /sbin/modprobe -r --ignore remove snd-intel8x0
> 
> ~ # Turn off IPv6
> alias net-pf-10 off
> alias ipv6 off
> alias usb-controller1 uhci-hcd

Right, so your modprobe.conf thinks that your USB controller requires
module uhci-hcd (strange that it says usb-controller1 and not just
usb-controller - perhaps that's a problem too?).

> lsmod returns:
> 
> [root localhost root]# lsmod
> Module Size Used by
> snd_intel8x0 30829 1
> snd_ac97_codec 58821 1 snd_intel8x0
> snd_pcm 83529 1 snd_intel8x0
> snd_timer 25413 1 snd_pcm
> snd_page_alloc 8393 2 snd_intel8x0,snd_pcm
> gameport 4033 1 snd_intel8x0
> snd_mpu401_uart 7361 1 snd_intel8x0
> snd_rawmidi 21733 1 snd_mpu401_uart
> snd_seq_device 6473 1 snd_rawmidi
> snd 45477 9
> snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
> soundcore 7713 1 snd
> nvram 10569 1
> parport_pc 21249 1
> lp 9133 0
> parport 35977 2 parport_pc,lp
> autofs4 20677 0
> aes_i586 38325 1
> airo_cs 5317 1
> airo 58465 1 airo_cs
> ds 12869 5 airo_cs
> yenta_socket 15937 1
> pcmcia_core 51336 3 airo_cs,ds,yenta_socket
> sunrpc 141861 1
> ipt_REJECT 5057 1
> ipt_state 1857 1
> ip_conntrack 25569 1 ipt_state
> iptable_filter 2369 1
> ip_tables 13889 3 ipt_REJECT,ipt_state,iptable_filter
> floppy 54001 0
> sg 28513 0
> scsi_mod 105360 1 sg
> microcode 5601 0
> dm_mod 47317 0
> button 4825 0
> battery 7117 0
> asus_acpi 9177 0
> ac 3533 0
> ext3 96937 2
> jbd 66521 1 ext3
> [root localhost root]#

No uhci-hcd module loaded. Try modprobe uhci-hcd and see what appears in
/var/log/messages and if there's any output from lsusb.

> The last fes lines messages in /var/log/messages: (but this is maybe
> not what we are looking for)
> 
> Oct 22 17:37:44 localhost bonobo-activation-server (root-7415):
> invalid character '#' in iid
> 'OAFIID:This#!!%$iid%^$%_|~!OAFIID_ContainsBadChars'
> Oct 22 17:39:25 localhost bonobo-activation-server (root-7439): iid
> OAFIID:BrokenNoType:20000808 has a NULL type
> Oct 22 17:39:25 localhost bonobo-activation-server (root-7439):
> invalid character '#' in iid
> 'OAFIID:This#!!%$iid%^$%_|~!OAFIID_ContainsBadChars'
> Oct 22 17:39:39 localhost bonobo-activation-server (root-7444): iid
> OAFIID:BrokenNoType:20000808 has a NULL type
> Oct 22 17:39:39 localhost bonobo-activation-server (root-7444):
> invalid character '#' in iid
> 'OAFIID:This#!!%$iid%^$%_|~!OAFIID_ContainsBadChars'
> Oct 22 17:43:00 localhost bonobo-activation-server (root-7491): iid
> OAFIID:BrokenNoType:20000808 has a NULL type
> Oct 22 17:43:00 localhost bonobo-activation-server (root-7491):
> invalid character '#' in iid
> 'OAFIID:This#!!%$iid%^$%_|~!OAFIID_ContainsBadChars'

Nothing relevant here.

Paul.
-- 
Paul Howarth <paul city-fan org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]