CodeHeads ch at
Sat Dec 3 23:57:47 UTC 2005

akonstam at wrote:
> On Sat, Dec 03, 2005 at 02:08:27PM -0500, CodeHeads wrote:
>>Hello all,
>>Got a problem:
>>I had a networked printer from linux to linux working. The print server 
>>is running FC4 and the laptop was running FC4 also. I redid the laptop 
>>to FC2. and now I am getting errors of "Unable to get printer status 
>>What is the path supposed to be for CUPS on the FC2 machine? I have 
>>tried the following:
>>Server=IP	Path=/var/spool/lpo
>>Server=IP	Path=/dev/usb/lp0
>>Server=IP	Path=/var/spool/cups
>>The printer is a HP OfficeJet 5500 series.  What I cannot understand is 
>>I had it working when both machines where running FC4.  Could this be a 
>>problem or is it permissions. Yes, the printer is shared. :)
> This is complicated for several reasons. Print sharing never really
> worked on FC2 as it does on FC4.
> Now the correct way (read the easiest way) to print through a server
> from a client in FC4 is to define the printer on the FC4 server using
> the CUPS web interface (localhost:631).
> Then on the client do not define it as a cups printer at all but in
> the file: /etc/cups/client.conf
> Change the line:
> ServerName
> to point at your print server.
> In FC4 that is all you need to do to  print to the printer from the client
> through the server, If the printer is defined in any way on the client
> remove the definition. But be careful. Remove the definition of the
> printer before you change the client.conf file because a definition of
> the printer will appear on the client transferred from the server once
> you have altered the client.conf file. Actually it may take 30
> seconds to appear.
> This is how it works under FC4. I have never tried this on an FC2
> machine but it is worth a try.
> If that does not work we can answer you original question once you
> clear up where are you trying to set these addresses because none of
> them look to useful to me. lp0 should certainly never appear network
> printer definition.
> -------------------------------------------
> Aaron Konstam
> Computer Science
> Trinity University
> telephone: (210)-999-7484

I was using the printconfig GUI.  I selected Networked CUPS (IPP) and 
for the server i entered the IP address and for the path (the 3 from the 
first post).  I might not have made it clear the first time. sorry about 

I will try what you selected and see what happens.


More information about the fedora-list mailing list