Question of retrieving data from a mirrored drive.

Les Mikesell lesmikesell at
Mon Dec 5 23:27:16 UTC 2005

On Mon, 2005-12-05 at 17:02, Michael Duffy wrote:

> I've a bit of a problem.  I need to get the data off of mirrored drive
> (2nd) it was controlled via a software array drive from redhat, with an
> ext2 file system.  I've tried to mount it on to several machines of
> various flavors: FreeBSD 5, FreeBSD6, Windblows, and Redhat 4.  None of
> them worked.  Any ideas on this?
> In the Redhat 4 'message' log, I see that it recognised the drive as a
> mirror and went looking for it's other half.

The only time it should do this is when you reboot the machine.

> If could not, and then
> seemingly dis-connected the drive. 

Finding the other half or not should have no effect on mounting,
which it won't do automatically in either case.

>  It as assigned the name hdc, hdc1,
> hdc2, hdc3, and hdc4.  None of these devices would mount.
> Mirroring does not seen to be of much use if I can't retrieve the data.

If it was really RAID1 you should be able to mount the hdcn partions
directly.  If the kernel detected the md devices at bootup you
may also be able to mount them as 'broken' mirrors which also work
fine.  A 'cat /proc/mdstat' should show the detected md devices.
What command are you using to mount and how does it fail?

  Les Mikesell
   lesmikesell at

More information about the fedora-list mailing list