FC4 up2date fatal RPM install error

Jim Cornette fc-cornette at insight.rr.com
Mon Dec 26 21:36:49 UTC 2005

David L wrote:

> I just tried to run up2date on my FC4 system and got an error during 
> installation:
> There was a fatal RPM install error.  The message was:
> There was a rpm unpack error installing the package: 
> kde-i18n-Polish-3.5.0-0.1.fc4
> I selected the only available option - "OK" and it exited up2date (it 
> didn't just abort installing that one package).  So I tried to run 
> up2date again and it found one new package to download (presumably one 
> that was changed during the 2 hours I had been running the previous 
> up2date).  It installed that new package, but didn't continue 
> installing other downloaded packages where it left off.  Now I suspect 
> I have a half updated system.  Some of the packages that were updated 
> no longer work... for example thunderbird no longer works.  How do I 
> recover from this?
> Thanks...
>                          David
> PS - It seems like I get errors every few times I run up2date... every 
> 6 months or so they're bad enough that my install is no longer 
> useful.  Fortunately that's about how often new releases come out, so 
> I usually just install the new release.  But I think it's about time I 
> learn whatever magic is required to overcome up2date problems.  Do I 
> just have bad up2date karma or is it as fragile as it seems to me?  My 
> computer at work and my computer at home are both currently broken wrt 
> up2date.  :(
> _________________________________________________________________
> Express yourself instantly with MSN Messenger! Download today - it's 
> FREE! http://messenger.msn.click-url.com/go/onm00200471ave/direct/01/
If up2date exited before completing its duty, you will have quite a few 
errors with libraries being updated for programs that did not get 
updated and require the new library.

I would change to your /var/spool/up2date directory and ensure that 
there is no kernel related rpms located in the directory. If there is 
some kernel related rpms, move them out of the way or run 'rpm -ivh 
kern*.rpm followed by rm kernel*.rpm.
After the install only packages are installed and moved out ot the way, 
run 'rpm --replacefiles --replacepkgs  *.rpm' from the 
/var/spool/up2date directory.

rpm -qa |sort >~/rpmlistings.txt

Or you might want to run as root, where user is the user directory (and 
owner) where you want the file saved to.
rpm -qa |sort >/home/user/rpmlistings.txt ; chown user:user 

This should give you a sorted listing of rpms that you can scroll 
through in order to verify no multi-version rpms for the exited up2date 
process are lingering on your system.

Hopefully, replacing the packages and files from /var/spool/up2date 
corrected the missing package problems that you experienced. Otherwise, 
you might want to remove the older packages entries from the database 
with the --justdb option given to rpm.


"Nuclear war can ruin your whole compile."
-- Karl Lehenbauer

More information about the fedora-list mailing list