An mp3 ripping yarn

David Fletcher fc at
Thu Dec 29 19:39:57 UTC 2005

I've given my son an mp3 player for Christmas and of course I would like him 
to be able to rip his CDs to mp3 files using Sound Juicer on his computer not 

Yes I know that you can also get portable Ogg Vorbis players. I saw some at 
Staples this afternoon. Unfortunately they're more than double the price of 
the MP3 player I bought together with a 1G memory card.

On my computer which is running FC3 I can rip to mp3 just fine, using the 
notes I compiled from the results of a couple of google searches:-

1) Put the following into /etc/yum.repos.d/Freshrpms.repo (might need to 
change the first line to reflect the FC issue number:-

name=Fedora Project $releasever - $basearch - freshrpms

2) Import the GPG key:-

rpm --import 

3) Install the plugins:-

yum install gstreamer-plugins-extra-audio

Now it should work!

Also might need to use yum install xmms-mp3 to get this working too.

I tried doing the same on his computer which is running FC4(replacing 
[freshrpms-fc-3] with [freshrpms-fc-4]). Everything seems to install OK but 
there is no mp3 option to select in the version 2.10.1 sound juicer on FC4. 
My FC3 installation has sound juicer version 0.5.14.

Now my first question:- Has the mp3 selection been deliberately compiled out 
of version 2.10.1 to prevent users ripping to mp3 at all even though the 
plug-in is available elsewhere?

Second question:- If this is so, is it being put back into FC5?

Something I found out this morning is that if I insert an audio CD and let it 
mount, I can then open it using Konqueror and browse to various folders, one 
of which is called "mp3", containing objects which when dragged to the hard 
drive causes Konqueror to rip tracks from the CD to mp3 files. Very nice, I 

This operation can be configured using the Sound & Multimedia - Audio CDs 
section of the KDE Control Centre.

Now my third question:- I cannot find the Audio CDs section in the Control 
Centre on the FC4 machine, and the same audio CD won't mount. Is it supposed 
to be there? If it is supposed to be there, the only explanation I can think 
of is that perhaps the CD drive in this machine is an old one that does not 
support some required functionality? If this is possible, can anybody please 
suggest the age at which a CD drive might be too old? I can always go out to 
the shops and buy a new one, but I'd like to feel reasonably sure that I'm 
spending the money for a good reason.

Finally, something else I tried was to yum remove sound-juicer from FC4, and 
replace it using an FC3 rpm from one of the mirrors. I also had to replace a 
couple of libraries using rpms from the same place to get it to install. That 
version under FC4 gave an error message. I can't remember the exact error 
message but it was something to do with not being able to access the CD 
drive, and a google search indicated that cdparanoia might be implicated in 
this problem. At this point I thought sod it and just put the FC4 machine 
back as it was.

But is there any possibility that cdparanoia was simply getting upset about 
the CD drive itself, for the same reason that Audio CDs doesn't show up in 
the Control Centre?

Many thanks to anybody who reads all this, and many many thanks to anybody who 
can help.

Dave Fletcher

Registered Linux user number 393408

I use and recommend the email service at 1 & 1
For domain registration, email and web hosting please visit:

More information about the fedora-list mailing list