[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: What package i must install to resolve...



----- Original Message ----- 
From: "Michael Schwendt" <mschwendt tmp0501 nospam arcor de>
To: "For users of Fedora Core releases" <fedora-list redhat com>
Sent: Wednesday, June 29, 2005 1:15 PM
Subject: Re: What package i must install to resolve...


> On Wed, 29 Jun 2005 13:04:48 +0200, Alexander Dalloz wrote:
>
> > Am Mi, den 29.06.2005 schrieb Michael Schwendt um 12:30:
> >
> > > Are you sure? What does your copy of libstdc++-3.4.3-22.fc3 provide?
> > > I think it's insufficient.
> > >
> > > I'd rather like to see what version of "taglib" is used here. The
> > > version from Extras needs libstdc++ from Core. But maybe it's a
> > > taglib from somewhere else?
> >
> > > Michael Schwendt <mschwendt users sf net>
> >
> > Hi Michael!
> >
> > $ rpm -q --provides libstdc++-3.4.3-22.fc3
> > libstdc++.so.6
> > libstdc++.so.6(CXXABI_1.3)
> > libstdc++.so.6(GLIBCXX_3.4)
> > libstdc++.so.6(GLIBCXX_3.4.1)
> > libstdc++.so.6(GLIBCXX_3.4.2)
> > libstdc++.so.6(GLIBCXX_3.4.3)
> > libstdc++34
> > libstdc++ = 3.4.3-22.fc3
> >
> > Hm, don't know where the taglib package would come from.
>
> FC4 provides libstdc++.so.6(GLIBCXX_3.4.4), so assumedly it's a taglib
> built for FC4, and the OP tries to install it with FC3. :-}

I just use yum. all the $releasever and vars are filled in at the repo confs
But i see when i do update also a lot fc4 and even fc5 packages selected.
So not me but some repo is mixing stuff.
I did disabled the testing ones.
I guess it comes from kde-redhat repo. It just suddenly happend.

here my rpm results
[root dev ~]# rpm -q --provides libstdc++-3.4.3-22.fc3
libstdc++.so.6
libstdc++.so.6(CXXABI_1.3)
libstdc++.so.6(GLIBCXX_3.4)
libstdc++.so.6(GLIBCXX_3.4.1)
libstdc++.so.6(GLIBCXX_3.4.2)
libstdc++.so.6(GLIBCXX_3.4.3)
libstdc++34
libstdc++ = 3.4.3-22.fc3
[root dev ~]# rpm -qp --requires taglib-1.3.1-0.1.3.kde.i386.rpm | grep
GLIBC
error: open of taglib-1.3.1-0.1.3.kde.i386.rpm failed: No such file or
directory
[root dev ~]#

yum update gives me this :
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package webmin.noarch 0:1.210-1.1.fc3.rf set to be updated
---> Package arts.i386 8:1.4.1-1.2.fc3.kde set to be updated
---> Package k3b.i386 0:0.12.1-1.2.fc3.kde set to be updated
---> Package SDL_mixer.i386 0:1.2.6-2.fc5 set to be updated
[
 rpm -qa | grep SDL_mixer
SDL_mixer-1.2.5-9

Also FC5 ?
]

---> Package ppracer.i386 0:0.3.1-4 set to be updated
[
rpm -qa | grep ppracer
No result.
This package is not installed why it wants to install now?
]

---> Package liboil02.i386 0:0.2.0-0.fdr.1.3 set to be updated
[ same as ppracer, liboil02 this is not installed]

---> Package kdegraphics.i386 7:3.4.1-1.3.fc3.kde set to be updated
--> Running transaction check
--> Processing Dependency: perl(Authen::PAM) for package: webmin
--> Processing Dependency: libtag.so.1 for package: k3b
--> Processing Dependency: perl(Mon::Client) for package: webmin
--> Processing Dependency: libIlmImf.so.2 for package: kdegraphics
--> Processing Dependency: libHalf.so.2 for package: kdegraphics
--> Processing Dependency: libIex.so.2 for package: kdegraphics
--> Processing Dependency: perl(Net::SSLeay) for package: webmin
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.4) for package:
ppracer
--> Processing Dependency: libImath.so.2 for package: kdegraphics
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package OpenEXR.i386 0:1.2.2-3.fc4 set to be updated
[ FC4! ]

---> Package perl-Mon.noarch 0:0.11-2.1.fc3.rf set to be updated
---> Package perl-Authen-PAM.i386 0:0.15-1.1.fc3.rf set to be updated
---> Package taglib.i386 0:1.3.1-2 set to be updated
---> Package perl-Net-SSLeay.i386 0:1.26-2 set to be updated
--> Running transaction check
--> Processing Dependency: libssl.so.5 for package: perl-Net-SSLeay
--> Processing Dependency: libcrypto.so.5 for package: perl-Net-SSLeay
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.4) for package:
OpenEXR
--> Processing Dependency: perl(:MODULE_COMPAT_5.8.6) for package:
perl-Net-SSLeay
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.4) for package:
ppracer
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.4) for package: taglib
--> Finished Dependency Resolution
Error: Missing Dependency: libstdc++.so.6(GLIBCXX_3.4.4) is needed by
package ppracer
Error: Missing Dependency: libssl.so.5 is needed by package perl-Net-SSLeay
Error: Missing Dependency: libcrypto.so.5 is needed by package
perl-Net-SSLeay
Error: Missing Dependency: libstdc++.so.6(GLIBCXX_3.4.4) is needed by
package OpenEXR
Error: Missing Dependency: perl(:MODULE_COMPAT_5.8.6) is needed by package
perl-Net-SSLeay
Error: Missing Dependency: libstdc++.so.6(GLIBCXX_3.4.4) is needed by
package taglib

Give me some more hints :)

Danny.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]