[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Solaris NFS clients go wonky when server went FC4->FC5



Folks, a bit of a puzzler... For a long time (years), have had
sparc-solaris8 NFS clients (well-patched) talking to a RH/Fedora NFS
server, recently FC4 (x86_64).  The mount options, dished out through
autofs, were (probably sub-optimally):

  -rw,nosuid,nodev,sync,retry=5,rsize=16384,wsize=16384,intr

These were lightly-used clients; it worked; everybody happy.

I yum-upgraded the server to FC5 (current kernel, nfs-utils).  It
works.. most of the time, but the clients now often-but-not-always
wander off into...

  NFS server foo not responding still trying
  NFS server foo ok

... with a 20-, 30-, 60-minute gap between the two being common (but
not predictably so).  Nothing in the server logs; only that in the
clients'.

Thinking that maybe my old-crufty set of mount options needed fixing,
I switched to a very simple set:

  -rw,nosuid,proto=tcp,vers=3,intr

Didn't make the slightest difference.

I have Linux clients, same mount options, same everything, which
worked fine before -- and they still do.  There have been no cabling
or other changes -- just the switch from FC4 to FC5 on the server.

Ideas?  Thanks,

Will


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]