[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora] Re: RPM Updates



Ashley M. Kirchner wrote:
> Todd Zullinger wrote:
>>Doesn't rpm work if you download those packages and run
>>
>>rpm -Uvh elfutils-libelf*
>    Nope:
> 
> rpm -Uvh i386/elfutils-libelf-*
> error: Failed dependencies:
>        elfutils < 0.125-1.fc6 conflicts with 
> elfutils-libelf-0.125-1.fc6.i386
>        elfutils-libs < 0.125-1.fc6 conflicts with 
> elfutils-libelf-0.125-1.fc6.i386
>        elfutils-libelf = 0.123-1.fc6 is needed by (installed) 
> elfutils-libs-0.123-1.fc6.i386
>        elfutils-libelf = 0.123-1.fc6 is needed by (installed) 
> elfutils-0.123-1.fc6.i386

Sorry.  Looks like that should have been

rpm -Uvh elfutils*

As Michael pointed out, rpm expects to have all of the packages needed
for the transaction specified on the command line.  I don't think
there is really any problem using rpm to do this install once you have
all the needed packages at hand, but it's certainly far easier to use
yum.  :)

On my system I have these:

elfutils-0.125-1.fc6.i386.rpm
elfutils-libelf-0.125-1.fc6.i386.rpm
elfutils-libelf-devel-0.125-1.fc6.i386.rpm
elfutils-libelf-devel-static-0.125-1.fc6.i386.rpm
elfutils-libs-0.125-1.fc6.i386.rpm

-- 
Todd        OpenPGP -> KeyID: 0xBEAF0CE3 | URL: www.pobox.com/~tmz/pgp
======================================================================
Forcing people to work without pay does not deserve to be called by a
pretty sounding phrase like 'public service'.
    -- Charles Champion

Attachment: pgpDxuXCTkaKc.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]