Fedora 7 and bcm43xx_mac802112

John Pierce john.j35 at gmail.com
Sat Jun 2 03:24:04 UTC 2007

> Under FC6 I was able to get my laptop (HP zv6015us with a Broadcom 4306
> wireless NIC) to work with the bcm43xx driver only if I disabled
> authentication on my AP.  You might give this a *brief* try.  That is,
> set your AP as open and see if you can connect.  If you can connect and
> you're sure that you have the authentication set up correctly on your
> laptop then it sounds like bcm43xx still doesn't like to authenticate.
> If you still can't connect, there's always ndiswrapper.  I'm currently
> running the 1.45 version of ndiswrapper with a kernel under
> CentOS 5 and the connection is very stable.  Also, I'm currently running
> WPA-PSK authentication.
> Cheers,
> Dave
Thanks for the reply Dave.

I have not tried to open the system, I will though.  I have tried the
ndiswrapper 1.45 on the stock kernel from the fedora 7 install, it is
2.6.21-1.3194.fc7.  I have not been able to get the ndiswrapper to
work either, I had it working with 1.27 on opensuse 10.2 which was a
2.6.18 kernel.

I have tried both hex and ascii for my key and neither works.  I must
admit this is the first time I have been able to get the system
scanning with the native driver bcm43xx_mac80211.

I will post back my results.

Registered Linux User 263680, get counted at

More information about the fedora-list mailing list