yelp dependency error

Chris G cl at
Fri Nov 9 09:24:06 UTC 2007

On Thu, Nov 08, 2007 at 06:49:56PM -0500, Mike A. Harris wrote:
> Chris G wrote:
>> A little while ago I reported a problem I had here with not being able
>> to load the gnome-terminal help, I found that it needed yelp to be
>> installed for the help to work.  I installed yelp and all was well but
>> couldn't quite work out why yelp had gone missing.
>> Now I have discovered why.  If you remove firefox it removes yelp with
>> it, even though other things require yelp for their help.
>> I had removed the 64-bit version of firefox and replaced it with the
>> 32-bit version which doesn't appear to have yelp with it.
>> OK, it's a bit of an odd dependency issue but there are good reasons
>> for wanting a 32-bit firefox on a 64-bit system.
> If you haven't tried "nspluginwrapper" on x86_64 yet, you might wantt
> to give it a whirl.  It allows you to run a number of 32bit plugins
> with the 64bit firefox on x86_64.  In particular it works pretty well
> with the Adobe flash plugin.  I haven't tried it with any other
> plugins, so your mileage may vary.
I did initially try the nspluginwrapper and it made some things work
but it does add an extra layer of confusion to getting Firefox as I
want it and in the end I found that running the i386 version was
simply much easier.

What I have done now is to install both the i386 and the x86_64
versions of Firefox and I have madified the script at /usr/bin/firefox
so that it runs the i386 version.  It means I have to remember to
modify that script very time I upgrade Firefox but it's a trivially
easy change so not a big deal.  

Chris Green

More information about the fedora-list mailing list