FC7 on my lappy, F8 dvd in drive, fresh powerup

Gene Heskett gene.heskett at verizon.net
Fri Nov 30 17:43:52 UTC 2007

On Friday 30 November 2007, Claude Jones wrote:
>On Friday November 30 2007 9:07:42 am Gene Heskett wrote:
>> I tried a yum upgrade 2 or 3 weeks ago, but it failed
>> litterally hundreds of dependency thingy's.  Maybe didn't do
>> it right, good instructs are hard to find.  Pointers, url's
>> welcomed.
>> Thanks, Claude.
>I did the following:
>I manually downloaded the release rpm for F8 and installed it for
>the Fedora repos and some of the other repos that I use (I think
>I found a couple of others including Livna)
>I then went through each of my .repo files in yum.repos.d and
>changed those that hadn't been updated (this usually involved
>looking at the URL's and changing each 'F7' to 'F8'
>I made sure that the repos I want to use were enabled, and those
>that I don't were not after the above procedure (in my case, I
>use Freshrpms, not Livna, so I had to disable Livna after
>installing the release rpm for Livna - I have Livna installed
>for occasional use, but I normally have it disabled)
>I then installed the latest kernel (I don't know if this is
>necessary, but, it was suggested in one of the howto's I used)
>I then ran yum update - this found a huge number of packages and
>failed on a couple of dependencies (yes, only a couple, not
I don't have as many repos, and I did go get the kde.repo, and its now 
spitting out an endless list of stuff to be updated.  One question though, in 
the interests of saving bandwidth, can I not make the dvd a first priority 
when the package there is the same as the one in the repo I'd have to 
download?  Its still pulling filelists.sqlite.bz2's.  Looks like I'll have to 
remove mplayer, it just exited.  Done, restarted.

I'd assume also that I should stop x when all the deps have been handled and 
do it from a tty shell?  ctl-c it when it starts to pull packages, stop x and 
resume?  Actually its ready, 100 new packages, 1187 to update, remove 5.
I think I'll just let it godoit.

>I removed the packages that were causing problems - in no
>instance were they things I couldn't do without, at least for
>the purposes of the upgrade
>I ran yum update a second time, and this time it worked - on both
>machines, there were about 1400 packages that got upgraded
>This is how it worked for me. Obviously, YMMV -- my repos are:
No>Freshrpms (enabled)
No>Adobe-linux (enabled)
No>Dries (disabled)
No>Dag (disabled)
Yes>Livna (disabled)
Yes>Fedora (Fedora and Fedora-updates enabled, the rest disabled)
No>atrpms (disabled)
No>Skype (enabled)
Yes>KDE-redhat (KDE-redhat - stable and testing enabled)
No>jpackage (disabled)
No>planetccrma (disabled)
No>olib-fedora (disabled)
>I can't remember where I found the howtos I used - I seem to
>remember following some suggestions posted to this list

Now, I'd assume that once I get the lappy sorted, I could do the same thing 
here?  First to F7, then to F8?

Thanks Claude, it looks like this is gonna work.

>Claude Jones
>Brunswick, MD, USA

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
National security is in your hands - guard it well.

More information about the fedora-list mailing list