grub problem

don vogt donvogt2001 at
Sat Feb 9 13:03:19 UTC 2008

I am stuck in a pretty complete disaster and grub
won't help me out of it. It is a long story, but here
is a summary
I bought a pci/USB2.0 card with the idea of digitizing
some slides.
I installed the card and after that fc7 wouldn't read
the card. So I rebooted into XP to see if it would
work there.XP started to boot and about 8 seconds
later the display changed to a blue screen with an
incomprohensible error message and froze.
 I use the XP system to access some sites that won't
work with linux, so I reinstalled XP (not a pleasant
experience!). I knew that would trash my grub setup on
the MBR, but I thought I knew how to redo grub from my
fc7 livecd.

The method I tried was to run grub and enter
find /grub/grub.conf
it answered (hd0,1)  (which is my /boot partition)
I entered   root (hd0,1)
no answer, just the prompt back
I entered setup (hd0)
it answered with some comments about searching for
some stage files. it found stages 1,2,and1.5
then it said "Running imbed /grub/e2fs-stage1_5 (hd0)
15 sectors asre embedded succeeded"
then it said install /grub/stage1 (hd0) (hd0)1+15
(hd0,1)/grub/stage2 grub.conf  succeeded "
 That all looks good to me so I backed out and
rebooted without the CD.
Instead of the grub menu I get a little trash and a
lot of blank screen.

I downloaded the rescuecd iso, burned it and booted
that and tried the same thing with the same result.

Here is my grub.conf in case it helps.

# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making
changes to this file
# NOTICE:  You have a /boot partition.  This means
#          all kernel and initrd paths are relative to
/boot/, eg.
#          root (hd0,1)
#          kernel /vmlinuz-version ro
#          initrd /initrd-version.img
title Fedora (

        root (hd0,1)
	kernel /vmlinuz- ro root=LABEL=main 
	initrd /initrd-
title Fedora (

        root (hd0,1)
	kernel /vmlinuz- ro root=LABEL=main 
	initrd /initrd-
title WIN98
	rootnoverify (hd0,0)
	chainloader +1
title XP
        rootnoverify (hd1)
	map (hd0) (hd1)
	map (hd1) (hd0)
	chainloader +1

Can Anyone see what I am doing wrong or have another
suggestion on how to get grub fixed.

More information about the fedora-list mailing list