WiFi LAN access, but not WAN access.

Pete Geenhuizen pgeenhuizen at pobox.homeunix.net
Mon Feb 18 23:07:16 UTC 2008

Not sure if this addresses your particular situation, but in my 
struggles to get WiFi to work with WPA, with both NDISWRAPPER and the 
cursed BCM mess I found this little gem which works for both FC6, F8 and 
now I'm on CentOS5 with both ndiswrapper and Madwifi driving an Atheros 
PCI card.

The interface comes up @ boot and when I login all is well.  I use 
kwifimanager as a quick and dirty method to monitor the WiFi for 
connection and speed info.

chkconfig {NetworkManager,NetworkManagerDispatcher,wpa_supplicant} off

add the following to the end of /etc/sysconfig/network-scripts/ifup-wireless

# wsrcc hack start.
# This seems to be the only way to get wpa networking and dhcpclient to work
# properly at boot
if [ ! -S /var/run/wpa_supplicant/$DEVICE ]  ;  then
    wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -i$DEVICE 
-Dwext -B
# wsrcc end end

Mike -- EMAIL IGNORED wrote:
> On Mon, 18 Feb 2008 18:29:47 +0000, Mike -- EMAIL IGNORED wrote:
>> On Mon, 18 Feb 2008 06:54:04 +0000, Da Rock wrote:
>>> ----------------------------------------
>>>> To: fedora-list at redhat.com
>>>> From: m_d_berger_1900 at yahoo.com
>>>> Date: Mon, 18 Feb 2008 04:48:05 +0000 Subject: WiFi LAN access, but
>>>> not WAN access.
>>>> On FC8 with my dual boot laptop, in the process of testing
>>>> wpa_supplicant with my Actiontec router, I had a situation in which I
>>>> could ping within my LAN, but but not the WAN. Other boxes on my LAN,
>>>> had no problem contacting the WAN. So I shut of the encryption, and
>>>> made unencrypted WiFi contact.  Still, I could contact the LAN but not
>>>> the WAN. Then I made a wired Ethernet connection from the test laptop.
>>>> In that case, everything worked for WAN and LAN. Then I went back to
>>>> wireless.  It all worked, with and without encryption.
>>>> So I am living happily ever after, but I fear I may be in a fool's
>>>> paradise.  Any suggestions?
>>>> Thanks,
>>>> Mike.
>>>> --
>>>> fedora-list mailing list
>>>> fedora-list at redhat.com
>>>> To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
>>> What is your dhcp settings for the wifi? Same as lan? Also check route
>>> settings- is the gateway correct for wifi? I had to set my dhclient to
>>> supersede gateway so that I had wan access on both lan and wlan.
>>> Hope that helps- maybe. Any further info (inc. vague topology) and or
>>> config might help to work out your sit.
>> [...]
>> I am running a dual boot laptop with WinXP and FC8.  WinXP makes the
>> connection with no problem.  I have tested both DHCP and static IP, and
>> I get the same results.
>> I have, I think, solved the problem.  It appears that both
>> wpa_supplicant and Network Service Control must me manually activated. 
>> Network Service Control showing "Active" is not good enough.  Depending
>> on the sequence of things, it may be necessary to click Deactivate (if
>> this closes the window, reopen it) and then click Activate.  It then
>> becomes fully functional.
>> I hope this is cleaned up in future versions.
>> Mike.
> I add that while this worked for my Actiontec router, I have not
> gotten by Vigor 2910G to work with it.
> Mike.

Unencumbered by the thought process.  
 -- Click and Clack the Tappet brothers 

More information about the fedora-list mailing list