How to mount 'virtual' file systems /proc and /sys ??

Gilboa Davara gilboad at
Fri Feb 22 16:13:38 UTC 2008

On Thu, 2008-02-21 at 11:31 -0800, Robinson Tiemuqinke wrote:
> Hello,
>  I am setting chrooted environments with Centos/Fedora
> Core distros recently. packages are installed in the
> chrooted environment without problems.
> Then when it comes to /proc and /sys 'virtual'(not
> real hardware) file systems I got confused -- some
> documents say I should run 'mount -t proc none /proc;
> mount -t sysfs none /sys' to mount /proc and /sys,
> while some others say commands 'mount -t proc proc
> /proc; mount -t sysfs sysfs /sys' instead. I don't
> know what is the difference between the source device
> name 'none' against 'proc' and 'sysfs'. Any one can
> shed a light onto this?
> In fact, I tried command 'mount -t proc kidding /proc;
> mount -t sysfs kiddingAgain /sys' to successfully
> mounted /proc and /sys without explicit problems;
> access to /proc/* and /sys/* worked fine as well. Then
> what are the purposes of the sourceDevice field for
> 'virtual' file systems? Thanks.
> Please help.

I'm not sure I managed to understand you question, but in-order to get a
fully functioning chroot environment (coupled with X support) I usually
issue the following commands:

$ mount proc /mnt/XXX/proc -t proc
$ mount sys /mnt/XXX/sys -t sysfs
$ mount /dev /mnt/XXX/dev -o bind
$ mount $HOME /mnt/XXX/$HOME -o bind
$ mount /tmp /mnt/XXX/tmp -o bind

- Gilboa
P.S. Sending the same message to multiple ML's is usually considered
-very- rude.

More information about the fedora-list mailing list