cannot set speed to 1000/FD

David Timms dtimms at
Tue Feb 26 10:11:49 UTC 2008

Steven C. Liu wrote:
> I recently replaced a FE 3Com card in my Linux server (hostname is 
> imladris) with a Netgear GigE card.  I am unable to set it to 1000FD, no 
> matter what I do.  I tried forcing it using 'ethtool -s', and setting 
> autoneg off and on.  Rebooting didn't help.  Using a different port on 
> my GigE switch/hub didn't help.
> BTW - I also put a duplicate Netgear GigE card into another Linux server 
> (hostname is numenor; additional NIC, not a replacement -- if it  
> matters).  On numenor, that NIC is at 1000FD.
> I have not yet tried swapping the port and ethernet cable between 
> imladris and numenor...
That would be a great first check - eliminate everything you can.

Are you using a cable with all 4 pairs correctly wired {for 1Gb}, 
whereas only two pair {for 100Mb} ?

Are you using a switch ? If not the crossover has to crossover 4-pairs 
correctly !

Is it a reasonable distance ? proper cat 6 cable ?


More information about the fedora-list mailing list