Burning CDs

Phil Bass phil at stoneymanor.demon.co.uk
Fri Feb 29 17:42:39 UTC 2008

Phil Bass wrote:
> I'm using Fedora 7 with all updates applied (except for a very recent
> Perl update that the update program couldn't find).
> I have been using xcdroast to save photos onto CDs. I always write
> multi-session CDs so that I can keep adding photos until the disk is
> nearly full. Some time over the past 5 months xcdroast seems to have
> stopped working. After some Googling I found that a kernel update was
> (probably) responsible and that it works when run as root. That would be
> an acceptable temporary solution, but for me it doesn't work. xcdroast
> starts up but never sees a CD in the CD-writer. Asking xcdroast to scan
> for devices causes it to hang. This is true for both ordinary users and
> root.
> After further investigation I found an alternative CD burning program
> called graveman and tried it. It hangs on startup for both ordinary
> users and root.
> Finally I tried to use the CD burning facility built in to Nautilus. The
> trouble now is that I can't find out whether Nautilus will write a new
> session to a multi-session CD. There's no option to control that AFAICS.
> So I haven't clicked the write-to-disc button to see if it works.
> If necessary I could learn how to use cdrecord (or is it wodim now?),
> but that's far more complicated than I need and I'm fast losing the will
> to live.  ;-) Any suggestions?
For the record, I managed to get xcdroast to work by manually specifying 
the device names (/dev/scd0 for my CD ROM drive and /dev/scd1 for my CD 
writer). Specifying the device in SCSI form 'dev=0,1,0' causes cdrecord 
to report:

WARNING: the deprecated pseudo SCSI syntax found as device specification.
Support for that may cease in the future versions of wodim. For now,
the device will be mapped to a block device file where possible.
Run "wodim --devices" for details.

Then after a pause of several seconds it goes into an infinite loop saying:

Unable to open this SCSI ID. Trying to map to old ATA syntax.This 
workaround will disappear in the near future. Fix your configuration.

Using device names of the form ATA:0,1,0 and ATAPI:0,1,0 cdrecord 
immediately loops producing this last message. It comes too fast to see 
if it was preceded by the 'deprecated syntax' message.

So I took the advice and ran 'wodim --devices', which produced:

 0  dev='/dev/scd0'     rwrw-- : 'TSSTcorp' 'DVD-ROM TS-H352C'
 1  dev='/dev/scd1'     rwrw-- : 'PHILIPS' 'DVD+-RW DVD8701'

Manually setting those device names using the xcdroast Setup screen 
fixed my problem, at least when run as root. xcdroast also recognizes 
the CD-ROM and CD-writer devices when run as an ordinary user, but I 
haven't actually tried to write to a CD in that mode yet.

Hope this is useful to someone.

Phil Bass (phil at stoneymanor.demon.co.uk)

More information about the fedora-list mailing list