[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: saned: permission problem with Deskjet_F300_series all-in-one



--- Nick Urbanik <nicku nicku org> wrote:

> On 03/01/08 05:52 -0800, Mr.Scrooge wrote:
> >Nick Urbanik <nicku nicku org> wrote: Dear Mr Scrooge,
> >On 02/01/08 17:16 -0800, Mr.Scrooge wrote:
> >>This might be a stupid question but did you give the saned group
> >>permission to use the scanner?
> >
> >Clearly not; I don't understand why I can use it and saned can't.
> >I also am not clear on the udev setup required to get it to work.
> >
> >>I installed an all in one device at
> >>home and i installed it under my account(via
> >>System>Administration>(root Password) and other users i.e. my
> >>girlfriend could not use it right away.
> >
> >As I said before:
> >>> Here are the permissions:
> >>> $ ls -l /proc/bus/usb/003/004
> >>> -rw-r--r-- 1 root root 147 2008-01-03 06:21 /proc/bus/usb/003/004
> >I think you are having the same problem that i was having. Root owns
> >the printer and has read/write permission. The group permissions( in
> >this case the group root belongs to which only includes root has read
> >and everyone else has only the read permission). It confused me as
> >well the first time. So you must use chmod to make the printer
> >accessible to everyone or try installing the printer while logged in
> >as a member of the saned group.
> 
> I don't see how that can help; you or I would do so as root.
> 
> >Can members of the saned group even see the printer? Does it show up
> >in the drop down when they try to print or is the postscript/default
> >the only thing present?
> 
> But why can I (as my own login) use the scanner?  Clearly I don't have
> write access to the USB device, yet it works for me, but not the
> saned user. Please look at the following carefully:
> 
> $ sudo -u saned scanimage -L
> No scanners were identified.
> $ sudo -u nicku scanimage -L
> device `hpaio:/usb/Deskjet_F300_series?serial=CN72FGM1CB04KH' is a Hewlett-Packard
> Deskjet_F300_series all-in-one
> $ sudo -u saned sane-find-scanner|grep ^found
> found USB scanner (vendor=0x03f0, product=0x5511) at libusb:003:005
> $ sudo -u nicku sane-find-scanner|grep ^found
> found USB scanner (vendor=0x03f0 [HP], product=0x5511 [Deskjet F300 series]) at libusb:003:005
> -- 
> Nick Urbanik              http://nicku.org          nicku nicku org
> GPG: 7FFA CDC7 5A77 0558 DC7A 790A 16DF EC5B BB9D 2C24 ID: BB9D2C24

I understand your confusion as i shared it at one time. When i installed the printer I was logged
in as myself but all admin tasks require root privilege. I entered my root password to access the
printing applet under administration. I installed the printer. I never bothered to check to see if
another user could use the printer, it worked for me and at the time that was enough. Later when
another user logged on and attempted to print I was confronted with this situation. The only thing
i can surmise is that because each user is assigned their own private group that the install using
the sudo only applies to the currently logged in user/group. Fedora does a couple of things
differently than other distros but as i recall i had a similar issue when running openSusE.Also by
all indications the scanner is detected but you simply cannot use it, which would tend to support
the idea that you have read but not write permissions to the device. Anyway you have little to
lose by trying, incorrectly installing a printer/scanner won't wreck your machine. Try installing
while logged in as a member of the saned group or wait for someone more knowledgeable to chime in.
I do not claim to be an expert, i am simply sharing what worked for me. I wouldn't mind someone
explaining it in more detail either. Sometimes you gotta take the bull by the horns and damn the
consequences!!Fortune favors the bold!!


      ____________________________________________________________________________________
Never miss a thing.  Make Yahoo your home page. 
http://www.yahoo.com/r/hs


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]