Periodic Fedora 9 system hangs with jumpy mouse

Steve Dowe steve.dowe at
Tue Jul 1 12:54:33 UTC 2008

I have this problem too.

Deron Meranda wrote:
> Okay, so Xorg ran away last night ... <snip>
> it should have been a completely idle unused system.
> Anyway, concerning the Xorg driver module, this is a brand new
> install of F9 (not an upgrade).  All the software is part of the base F9
> repo; nothing 3rd party was added.  Everything was auto-detected.
Ditto.  I have the most up to date versions of X, etc at the time or 
writing.  Same kernel too (
> The Xorg driver chosen for this was:
>    /usr/lib/xorg/modules/drivers//
> My screen is 1440 x 900 x 24, monitor is  DELL E198WFP
Mine's 1680x1050.  Using an HP Compaq 6715b laptop with ATI Radeon 
Express X1250,
>> from level 3 boot, remove driver, then use 'yum install' to bring your
>> driver back in and reboot to load it. driver may be fried.
> The driver is coming from the package xorg-x11-drv-ati-6.8.0-14.fc9.i386
> I did an rpm verify on it,
>    rpm -V -v xorg-x11-drv-ati-6.8.0-14.fc9.i386
> and that said all the files were intact and correct.
Again, same.  My drivers seem to be present and correct.
>> kde, gnome? have you tried any minimal desktops? something may, tho i
>> would doubt, be different in how you bring up x.
> Haven't tried other desktops other than Gnome, but I have disabled
> all the fancy effects, etc.
I can confirm this occurs in both KDE and GNOME on my system.
> The system runs perfectly fine; until that magic moment when the
> Xorg process runs away.  Or is that the kernel that is running away?
> I wish I knew how to debug the kernel better; because it just doesn't
> appear to be a user-space problem.
The cause of this problem on my system seems to be when dragging 
(resizing) a window.  X then seems to hang, the pointer gets jumpy and 
the whole desktop is unresponsive.  Being SSH'd in from another machine, 
I could see Xorg at 99-100% CPU.   This never seems to happen when 
dragging a whole window, just when I try to resize one.  I haven't 
noticed this happening at all by using a scroll bar (but I'm not saying 
this fault hasn't been triggered that way too..).  The only way I can 
recover is a hard reboot - holding down the power button.  Issuing "init 
6" or "reboot" makes no difference - it just hangs, which makes me think 
this is kernel- rather than X-related..  :-(

I'm afraid I cannot offer the same diagnostics as Deron without a little 
instruction, but I'd like to help to resolve this.. ;-)

FWIW, I'm downloading the debug flavour of the current kernel.  I'm 
going to reboot into that and see if I can get more output in the log(s)...

Is it possible that the Radeon driver can be triggering a bug in the 
kernel (which hangs X)?

All the best,

More information about the fedora-list mailing list