Fedora 9 Openchrome drv HP w2207h Monitor was: Re: help with setting up graphics

Antonio Olivares olivares14031 at yahoo.com
Thu Jul 3 17:00:21 UTC 2008

--- On Thu, 7/3/08, Beartooth <Beartooth at swva.net> wrote:

> From: Beartooth <Beartooth at swva.net>
> Subject: Re: Fedora 9 Openchrome drv HP w2207h Monitor was: Re: help with setting up graphics
> To: fedora-list at redhat.com
> Date: Thursday, July 3, 2008, 9:20 AM
> On Wed, 02 Jul 2008 14:12:29 -0700, Antonio Olivares wrote:
> 	[...]
> > I missed your previous posts, maybe clicking real
> fast, but I have an
> > integrated video in the motherboard and I use
> OpenChrome driver.
> > 
> > [olivares at localhost ~]$ su -
> > Password:
> > [root at localhost ~]# lspci
> > 00:00.0 Host bridge: VIA Technologies, Inc. K8M890CE
> [...]
> 	Somewhere in there, I did hit a K8M890, but not with the
> CE.
> > [...]  What I did to fix my situation was the
> > following:
> > 
> > Change inittab:5 to 3, that is from level 5 to level 3
> and then type
> > startx.
> 	Hmmm ... With mine, startx as user works *after* I've
> gone 
> through all the screens Fedora gives you when it can't
> start X -- 
> including running what appears identical to the display you
> get with 
> system-config-display, and changing both the Settings and
> Hardware 
> entries *back* to what I had when I shut down last. Why it
> doesn't keep 
> them, as it always used to, I don't know.
> 	I couldn't make sense of what I found by searching
> inittab; so 
> I'm probably missing something. I'm guessing that I
> could simply edit /
> etc/grub.conf, putting a 3 after the first kernel entry.
> Then it would 
> boot into level 3; I could log in as user, and simply
> command startx. Is 
> that right?
Well you could do that, but it is easier as root user to do the following: 

$ su -

open up with an editor of your choice and edit /etc/inittab

change the line "id:5:initdefault:" to "id:3:initdefault:"
and that will start the system in level 3.  

[root at localhost ~]# cat /etc/inittab 
# inittab is only used by upstart for the default runlevel.
# System initialization is started by /etc/event.d/rcS
# Individual runlevels are started by /etc/event.d/rc[0-6]
# Ctrl-Alt-Delete is handled by /etc/event.d/control-alt-delete
# Terminal gettys (tty[1-6]) are handled by /etc/event.d/tty[1-6] and
# /etc/event.d/serial
# For information on how to write upstart event handlers, or how
# upstart works, see init(8), initctl(8), and events(5).
# Default runlevel. The runlevels used are:
#   0 - halt (Do NOT set initdefault to this)
#   1 - Single user mode
#   2 - Multiuser, without NFS (The same as 3, if you do not have networking)
#   3 - Full multiuser mode
#   4 - unused
#   5 - X11
#   6 - reboot (Do NOT set initdefault to this)

> 	Or, as a prior experiment, I could edit the kernel line
> from the 
> grub boot-up splash, try init 3 that way, and only actually
> edit 
> grub.conf if the experiment succeeds.
> > [...]  I also
> > use Slax Linux on this machine and when the machine
> booted and logged in
> > automatically to X, the lines appeared, but then, I
> booted in text mode
> > and created a module for the OpenChrome drivers
> > 
> >
> http://www.slax.org/modules.php?action=detail&id=713
> 	Now I'm very confused, in part perhaps because I know
> nothing at 
> all about slax. It looks to me as if that site is offering
> to download 
> something to run under that OS, rather than Fedora. Not the
> case?
Yes, it is a module, that will run under Slax not Fedora.  Fedora has the driver built in.  

[root at localhost ~]# rpm -qa xorg-x11-drv-o*
[root at localhost ~]# 

In slax, it was not there so I downloaded the (OpenChrome)driver and built it using the rules for that system(Slax) and I have the same functionality that I do under Fedora with it.  I just start slax in text mode, load that module referenced above and configure the X window with xconf and then type startx and I have a much better experience than with the default driver loaded there.  

In Fedora I tried different things and it did not work for me.  So I tried changing xorg.conf and still the same, I did Xorg -configure as root and changed xorg.conf and still no go.  I went back to the original and started in level 3.  Then I tried to play a movie and the lines that appeared did not appear and it solved the problem for me.  

> > I started X with startx and the lines did not appear. 
> Problem was
> > solved for me.  I hope that this helps you with your
> problems.
> 	I can't imagine why startx would work immediately
> after logging 
> in in text mode, without touching anything that affects the
> configuration 
> of X; and it seems a strange, roundabout approach. But
> I'm willing to try 
> it, if I understand aright what it is I'm to try.
> -- 
> Beartooth Staffwright, PhD, Neo-Redneck Linux Convert
> Fedora 8 & 9; Alpine 1.10, Pan 0.132; Privoxy 3.0.6;
> nine (count 'em -- nine) different browsers
> Remember I know precious little of what I am talking about.
> -- 

I will attach xorg.conf here in case it might help.

[root at localhost ~]# cat /etc/X11/xorg.conf 
# Xorg configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"

Section "InputDevice"
# keyboard added by rhpxl
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"

Section "Device"
	Identifier  "Videocard0"
	Driver      "openchrome"

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24

[root at localhost ~]# 

Hope this helps fix your issues.  




More information about the fedora-list mailing list