Fedora 9 Openchrome drv HP w2207h Monitor : UPDATE

Beartooth Beartooth at swva.net
Mon Jul 7 15:02:08 UTC 2008

On Sun, 06 Jul 2008 15:56:37 +0000, Beartooth wrote:

> On Fri, 04 Jul 2008 02:20:14 +0200, Björn Persson wrote:
> 	[...]
>> I don't understand it either but similar things happen to me. If I boot
>> into runlevel 5 I only get a black screen. If I boot into runlevel 3,
>> log in as root and run "init 5 ; exit", then X starts just fine. I've
>> described the problem here:
>> https://bugzilla.redhat.com/show_bug.cgi?id=448340
> 	I'll take a look at that shortly, thanks.
>         Meanwhile, I did manage to get #1 as well as #2 machine to run
> F9;  but unless/until I hear better from Frank Murphy, I have to boot
> both in init3, log in as root, and play with the X configuration first
> by editing /etc/X11/xorg.conf and then by running system-config-display.
> That gives me a weird error message, something to the effect that the
> connection to the Xserver is temporarily unavailable. But if I then log
> root out and my userid in, I can command startx, and it takes a while
> but works.
> 	Next time I have to shut one of them down, or sooner if I get to
> it, I'll try your way instead; it certainly sounds shorter and easier.
> And, come to think of it, last time I did mine, I didn't change anything
> with either my editor or my config command; just ran them, logged root
> out and userid in.

	Yesterday evening we had a short power failure, about the time 
I'd've normally been getting offline anyway; so I shut everything down, 
all the way to the UPSs. This morning I've just brought up my #2 machine, 
the one with the nvidia video card, which has long been running F9.

	I tried Bjorn Persson's shorter way first. No joy. After init 5, 
I had a couple of failures among the messages on the screen,  and then it 

	One failure, new to me afaik, said : 

	=====		=====		=====
 rpc.idmap: Unable to create user id mappings: FAILED
Starting router discovery FAILED [but during init 3 boot it had handled 
not only eth0 but ntp time synch -- so it was connecting, somehow.]
Starting NetworkManager daemon                 OK
	=====		=====		=====

	NMd may have been OK, but something wasn't; everything hung at 
that point. After a long time, I tried Ctrl-Alt-Backspace; no visible 
result. Ctrl-Alt-Delete got a message, repeated six or eight times, 
saying those keys had been pressed, and the machine was going down -- but 
it didn't. It hung again there. 

	So I tried the reset button, and that worked.

	At the grub splash, I edited the first kernel to add a 3, and 
booted. But when I got my prompt, and logged in as root, I tried first 
"nano -w /etc/X11/xorg.conf" -- and made no changes. (It said, then, that 
livna nvidia, or whatever, had created it.) Both the monitor section and 
the screen section had 1280x1024. (The videocard section had, iirc, vesa.)

	So I commanded system-config-display. The hardware tab called 
itself autoconfigured, and when I told it to let me, it came up with 
generic CRT; I changed that to 1280x1024 LCD, and then the settings from 
800x600 to 1280x1024.

	It gave messages saying :

	=====		=====		=====
Couldn't start X server on card 0
   "      "    "   "    with old config, trying with a fresh configuration
Window manager warning: Fatal IO error 11 (Resource temporarily 
display ': 17.0'
	=====		=====		=====

	There it stopped, and gave root's prompt back. I logged out, and 
back in as user; commanded startx; it sat there ten or twenty seconds 
with the monitor showing shaded horizontal gray bands; and then came up 
almost normally.

	xorg.conf now says it was created by system-config-display; and 
the videocard driver is set to nv.

	The apps I had left on when shutting down were all or almost all 
in the upper left workspace, and my gnome terminal had only one tab and 
was not quite the right size nor in quite the right place. But otherwise 
it seemed normal, except that privoxy wasn't running.

	Now I'll go try machine #1, which has a VIA card -- and which, 
yesterday or the day before, I had tried yet again to upgrade from F8 to 
F9 -- successfully, this time, at last, afaict (except that it had not 
been through a reboot). I'll make those results a separate post, when I 
have them. Stay tuned.

Beartooth Staffwright, PhD, Neo-Redneck Linux Evangelist
Remember I know little (precious little!) of what I'm talking about.

More information about the fedora-list mailing list