that old GNU/Linux argument

Antonio Olivares olivares14031 at
Sun Jul 20 01:22:36 UTC 2008

> >Does anyone actually compile anything today?
> >Apart from developers, of course.
> Yes we users sure do Timothy:
> [root at coyote /]# uptime
>  20:40:56 up 5 days, 21:32, 25 users,  load average: 0.06,
> 0.07, 0.05
> [root at coyote /]# uname -a
> Linux coyote.coyote.den 2.6.26 #1 PREEMPT Sun Jul 13
> 22:50:19 EDT 2008 i686 
> athlon i386 GNU/Linux
> I'm also trying to get OpenMovieEditor built and
> installed, but it appears the 
> OpenGL and GLX being shipped from mesa through fedora has
> been emasculated.  
> According to the config.log of the failed configure of
> dmerlin, a dependency 
> OpenMovieEditor needs, at least 6 functions it expected to
> find have been 
> expunged from the libraries and headers.
> I'd be very interested in hearing the reasons behind
> its being stripped like 
> that.
> Its also interesting that I'm now posted 2 queries
> about it to this list, both 
> so far have been greeted by total silence.  Its as if its
> not a fedora problem 
> if its not generated by a fedora blessed rpm.
> The NIH syndrome in full bloom.
> -- 

I saw the posts, but since I do not know enough about the items, I did not respond.  Which many might not know or wish that you used rpms/yum to install the software.  Does livna, atrpms, freshrpms provide those kinds of packages?  I do not know for sure.  

This is something that bites back, I have tried multiple times to install vlc media player from source, and I downloaded all the dependencies and installed them and it still fails with the reason that I do not have a ffmpeg-devel and I did have it.  I installed the livna one, but for some updates I would get lots of conflicts so I decided to trash it.  I got content with one media player only, mplayer.

I tried xine also by compiling, but the stripped Fedora version interferes with the one that can play dvds, so if I tried to remove it, It would remove KDE, and I decided not to pursue that either.  I gave up and did not even ask why KDE depended on xine-lib-1.??, the free one(without the ability to play dvd's out of the box).  

When moving to gcc 4.3, the libid3tag-,libmad stuff

2 out of the 3 worked, but one did not, and thus I cannot get rid of the k3b does not have mp3 support, you need to install .... :(

I have been happy to run as it is and live with the nag screen :) 

Post your errors.  Then and only then someone may respond if they know what you can try :)




More information about the fedora-list mailing list