that old GNU/Linux argument

Gene Heskett gene.heskett at
Sun Jul 20 03:03:36 UTC 2008

On Saturday 19 July 2008, Antonio Olivares wrote:
>> >Does anyone actually compile anything today?
>> >Apart from developers, of course.
>> Yes we users sure do Timothy:
>> [root at coyote /]# uptime
>>  20:40:56 up 5 days, 21:32, 25 users,  load average: 0.06,
>> 0.07, 0.05
>> [root at coyote /]# uname -a
>> Linux coyote.coyote.den 2.6.26 #1 PREEMPT Sun Jul 13
>> 22:50:19 EDT 2008 i686
>> athlon i386 GNU/Linux
>> I'm also trying to get OpenMovieEditor built and
>> installed, but it appears the
>> OpenGL and GLX being shipped from mesa through fedora has
>> been emasculated.
>> According to the config.log of the failed configure of
>> dmerlin, a dependency
>> OpenMovieEditor needs, at least 6 functions it expected to
>> find have been
>> expunged from the libraries and headers.
>> I'd be very interested in hearing the reasons behind
>> its being stripped like
>> that.
>> Its also interesting that I'm now posted 2 queries
>> about it to this list, both
>> so far have been greeted by total silence.  Its as if its
>> not a fedora problem
>> if its not generated by a fedora blessed rpm.
>> The NIH syndrome in full bloom.
>> --
>I saw the posts, but since I do not know enough about the items, I did not
> respond.  Which many might not know or wish that you used rpms/yum to
> install the software.  Does livna, atrpms, freshrpms provide those kinds of
> packages?  I do not know for sure.

All I could (rpmfind)find was debug packages for a version about 2 releases 
earlier.  For Mandriva.

>This is something that bites back, I have tried multiple times to install
> vlc media player from source, and I downloaded all the dependencies and
> installed them and it still fails with the reason that I do not have a
> ffmpeg-devel and I did have it.  I installed the livna one, but for some
> updates I would get lots of conflicts so I decided to trash it.  I got
> content with one media player only, mplayer.

Been there too. :(

>I tried xine also by compiling, but the stripped Fedora version interferes
> with the one that can play dvds, so if I tried to remove it, It would
> remove KDE, and I decided not to pursue that either.  I gave up and did not
> even ask why KDE depended on xine-lib-1.??, the free one(without the
> ability to play dvd's out of the box).

The reasons to dump fedora, with its 'run only what we want you to run" attitude 
have got the balances just about to tip over to a non-us distribution.

>When moving to gcc 4.3, the libid3tag-,libmad stuff
>2 out of the 3 worked, but one did not, and thus I cannot get rid of the k3b
> does not have mp3 support, you need to install .... :(

I don't seem to have a need for that as the main thing I use k3b for is burning 

>I have been happy to run as it is and live with the nag screen :)
>Post your errors.  Then and only then someone may respond if they know what
> you can try :)

Well, we are hijacking a thread here, but here is a snippet:

>configure:25733: checking for library containing glAccum
configure:25774: gcc -o conftest    conftest.c  -lSM -lICE -lX11 -lXext -lX11  
/tmp/ccmFvTW9.o: In function `main':
conftest.c:(.text+0x12): undefined reference to `glAccum'
collect2: ld returned 1 exit status
configure:25780: $? = 1
configure: failed program was:
| /* confdefs.h.  */
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE "gmerlin"
| #define VERSION "0.3.7"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| #define SIZEOF_LONG 4
| #define SIZEOF_FLOAT 4
| #define SIZEOF_DOUBLE 8
| #define HAVE_VASPRINTF 1
| #define HAVE_LRINT 1
| #define HAVE_LRINTF 1
| #define ENABLE_NLS 1
| #define HAVE_GETTEXT 1
| #define HAVE_DCGETTEXT 1
| /* end confdefs.h.  */
| /* Override any GCC internal prototype to avoid an error.
|    Use char because int might match the return type of a GCC
|    builtin and then its argument prototype would still apply.  */
| #ifdef __cplusplus
| extern "C"
| #endif
| char glAccum ();
| int
| main ()
| {
| return glAccum ();
|   ;
|   return 0;
| }

And there are several more similar function not found failures, and they 
culminate in:
configure:25903: checking for library containing glXChooseVisual
configure:25944: gcc -o conftest    
conftest.c -lGLU  -lSM -lICE -lX11 -lXext -lX11  >&5
configure:25950: $? = 0
configure:25978: result: none required
configure:26023: result: yes
configure:26067: error: Gmerlin needs OpenGL and GLX

Both of which are fedora installed versions along with the -devel matching 
header files in /usr/include.

Thanks Antonio.

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
* |Rain| prepares for polygon soup
<|Rain|> sweet merciful crap, it works?
* |Rain| faints

More information about the fedora-list mailing list