SElinux concerning symlink?

Craig White craigwhite at
Thu Jul 24 20:49:50 UTC 2008

On Thu, 2008-07-24 at 20:45 +0000, Mike wrote:
> Mike <mike.cloaked <at>> writes:
> >
> > selinux-preventing-ssh-passwordless-login/
> > 
> > The above is on a single line - I had to break the line entering the url
> Following the advice in that link I did
> touch /.autorelabel;reboot
> This reverted the system so that ssh in failed as it had in the first place
> so I had to fix the context for /opt/ using restorecon again....
> This put me back in the position where I can ssh in but only giving the 
> password - passwordless login is still not possible.
> I tried restorecon -v /opt/Local/home/mike/.ssh/authorized_keys2 but
> this made no difference - and I still cannot login without the password.
> The sealert message suggests doing restorecon -v './authorized_keys2' 
> and I had tried but this does not fix the problem.
> Hence there seems to be a bug in the SELinux policy on this issue? 
I would doubt that.../opt is not a usual place for users $home
directories and thus the policy for files in that tree would not be
suitable for the method you are using.


More information about the fedora-list mailing list