F10 automatic F10 upgrades to F11?

Kevin J. Cummings cummings at kjchome.homeip.net
Thu Jul 23 23:05:43 UTC 2009

On 07/23/2009 05:30 PM, Daniel B. Thurman wrote:
> Ok, I tried the text mode (using net-install CD), and
> I get the same failure as with the preupgrade program.
> The net-install CD does not update grub with the boot
> code whereas preupgrade does. The net-install CD appears
> to have affected my F-10 yum repos when running in F10,
> as yum now updates as F11, yet fails to complete due
> to an older (F10) packagekit conflict. I have a feeling
> that my F10 yum/rpm is now hosed. I am still able to
> run as F10.
> So far as upgrades go, it does not worked for my
> (old) computer. I have wasted 2-3 weeks over upgrades
> and doing a fresh install would have been much faster,
> or so it seems.

Dan, I've just finished 2 upgrades and a clean install.  And I have 3 
different stories.....


1) Dell Dimension 3000:  fresh install.

	Could not use the F11 install DVD.    Anaconda errors out.

	Could use the F10 install DVD, so I installed F10.
	I could then use preupgrade to upgrade to F11.
	The only problem I had was that the sound card output
	was selected to the wrong device.  Resetting it fixed my sound.
	The video card is an old nVidia TNT card and works well enough
	with the free drivers for basic video.

2) AMD 2600+ ABIT server:  Upgrade from F8  (This is my main home server!)

	I tried to go F8->F11 with preupgrade.
	Once again, anaconda bombed after downloading all the packages.

	I ran into a number of separate problems:

	a)  Not enough disk space (/usr needed 770MB, and I didn't
		have it!), I had to buy a new disk, copied the
		partitions over to new larger ones, and tried again

	b)  preupgrade insisted on changing my disk LABELs into UUIDs in grub. 
  I spent lots of time figuring out the new UUIDs for fstab.
I still have 2 partitions to copy over (from a 3rd drive) before I can 
reuse the old (larger) disk.

	c)  preupgrade botched the finding of the /boot stuff
		(to be fair, the old config had a .boot partition,
		the new one didn't)  I fixed it by hand and then ran

	d)  anaconda still failed to find the previous install.

	e)  I tried the F11 install DVD, and it failed as well.

	f)  I then tried the F10 DVD, and it also failed my upgrade.

	I finally fixed all this by preupgrading to F10 instead of F11.
	This worked!  (go figure!)  The install finished.

	I am now tracking down a number of smaller problems (after finding and 
updating some not-so-common RPMs I had been using).  I ended up adding 
the city-fan repo for some of my perl/email stuff.

	After updating sendmail-milter-spf, spf-milter won't start.
It dies with an error message (see my previous email on the subject).

	NFS is not working right.  I can access the partitions locally,
but across NFS they cause a hang in the "D" state (according to top) and 
never return.  This worked just fine under F8.  This is haging up my use 
of dosbox and autofs to the server.

	Cups was "turned off" after the upgrade.  I had to "chkconfig --add 
cups" to get it to work again.  Oh yeah, a cups update came through soon 
after, and I had to re-enable it again....

	the updates repo was disabled.  (Is this related to the updates-newkey 
stuff?)  I had to re-enable it by hand in order to start the updates 
flowing.  Along with this, I had atrpms disabled (because Axel deleted 
his F8 repo after F8 was EOLed), so I had to re-enable by hand and 
update the atrpms stuff after I figured that out.

	Clamav-milter did not work right away, but this may be related to the 
updates repo problem.  After I updated, it started to work.

	The nvidia-96xx stuff did not get updated.  I got those from rpmfusion. 
  I ended up removing those old RPMs after the install and installing 
and enabling the nouveau driver.  Since I have a GeForce-6200 video card 
that I use with MythTV, I may end up re-installing the nVidia drivers 
later to be able to use the Xvmc stuff (I haven't looked at it yet!)

	I tripped over the mpg123/mpg321 endless loop of obsoletes on every 
update until I excluded one of them from ever updating again.
(grumble, grumble, grumble!)

3) I upgraded my F9.x86_64 laptop.  The plan was to go to Rawhide.

	preupgrade downloaded all the files, and the subsequent reboot failed 
with the same anaconda failure as my previous uses of preupgrade.

	However, I was able to use preupgrade to install F11.

	This worked remarkably well (OK, I ran across one very *slow* file 
about 10% of the way in, and rebooted the machine and started preupgrade 
again.  This time it finished.)  2255 RPMs got upgraded across 3 RPM 
repos (Fedora/Updates, RPMFusion, and ATRPMs).

	Only minor problems that were easily fixed:

	fglrx was never upgraded.  However, the radeon driver (finally) seems 
to be working well for me.  I haven tried MythTV with it yet, so, ....

	Practically none of my Thunderbird addons came up working.  I was able 
to fix my version ThunderLed3.0BETA to work for me (I did it once before 
going from FC6 to F9, even though it is basically unmantained, there has 
been no new release in over a year!).  I was able to find a version of 
Lightning that worked, and I was also able to find a version of Provider 
for Google Calendar.  (OK, both were from Mozilla nightly builds, and I 
had to hack them to work with 3.0b2 instead of the 3.0b3 they were built 
for.)  I still cannot find a working version of enigmail.  Enigmail is 
now in the RPMFusion repo (thunderbird-enigmail) but the F11 x86_64 
version is for Thunderbird 2.0, not the Thunderbird 3.0b2 that ships 
with F11.  B^{
For the rest of the addons I can probably wait on until ThunderBird 3.0 
gets released.

	Similar story for my Firefox addons.  I can wait for the release of 3.5....

	Sound has been working OK for me so far (knock on wood).

	The same can be said for NetworkMangler (iwl3945 driver) so far.
I never had to plug into my ethernet during this process.

	I did run into the .i586 update problem recently under discussion, but 
removal of kdepim took 8 other files with it and that prevented 34 other 
.i586 RPMS from being installed as dependencies.  (yes, I tried to 
re-install kdepim, and I found 38 .i586 RPMS trying to be installed 
along with the 4 .x86_64 RPMs.)  The problem update was of a single 
file:  xine-lib.i586.  Once I removed this file (it took all versions of 
kdepim with it and a couple of other RPMS as well that I decided I don't 
really need).

	I am slowly removing the unnecessary x86 RPMs from this system, but I 
still use a few (AdoeReader for one) and that is where my problems 
probably begin....

	More input as I stumble across it!

Kevin J. Cummings
kjchome at rcn.com
cummings at kjchome.homeip.net
cummings at kjc386.framingham.ma.us
Registered Linux User #1232 (http://counter.li.org)

More information about the fedora-list mailing list