ProFTPD not showing all directorys.

Mark Evers beheer at
Sun Dec 18 00:32:10 UTC 2005

Well, SELinux handed me another problem, i've been reading into the hoping i would get my answer,
without luck.

The problem is, when i connect to my FC4's Proftpd server i'm missing alot of directorys and files, and they do excist, i checked using SSH
At first i could only see the "homes" directory, then i tried a fixfiles relabel, it brought back some dir's, but not the ones that are most important like public_html.
Then i tried to disable SELinux to see if it's really SELinux related, and like magic, there are the missing dir's.

What i want, but can't find is a way for users to have full access to there home dir, they are chrooted so they can't look "beyond" there own home dir, and still use SELinux.
To be honest, i'm verry new to SELinux and i'm still trying to figure this out, i like the idea of security alot, but i find it hard to get information about it, like how to check what policys are enabled, and what policys can be added.

I've tried the system-config-security-level, and the only thing it showed me was the firewall.
I'm using Shorewall so that's not usefull to me.

I hope someone can help out.


Mark Evers
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the fedora-selinux-list mailing list