FC5t3 - rpm -e hangs up

Jim Cornette fct-cornette at insight.rr.com
Wed Mar 1 03:32:35 UTC 2006

Jan Andrejkovic wrote:
> Hello,
> I have upgraded FC4 to FC5t3. I had some xen problems therefore I have 
> decided to reinstall xen packages.
> But when I try
> rpm -e kernel-xen-hypervisor-devel or rpm -e kernel-xen-guest-devel rpm 
> hangs up and eats almost 100% cpu for long time.
> I need to use kill -9 to stop it.
> I have tried to do
> rm -f /var/lib/rpm/__db*
> and
> rpm --rebuilddb
> but nothing helped after those commands - it hangs again.
> I have also tried rpm -e --justdb but it did not help either.
> Initially it was "yum remove" which hanged first. But as far as I know 
> it uses rpm therefore I report this as rpm problem.
> Does anybody have the same problem or can anybody tell me some 
> workaround how I can remove those packages manually and possibly rebuild 
> database without them?
> Thank you very much,
> Jan

If rpm is consuming a lot of cpu percentage in regular boot, have you 
tried runlevel 1 or booting into rescue mode? Are the actions the same 
with cpu usage?
There is an option to run rpm in rescue mode by issuing some parameter 
to reference the root in terms where rpm from the rescue CD is used and 
rpm removal/addition is performed in reference to /mnt/sysimage. I 
believe it was used successfully when some had problems with i386 arch 
packages were installed instead of the proper i686 rpms.

The documentation is scarce for rescue mode and rpm. I found RHL 7.2, 9 
and RHEL4 The link is for RHEL4 which should be close to current 
information anyway.


If the rescue mode link does not help, how are others who upgraded from 
FC4 to FC5T3 systems reacting?

Rawhide after FC5T3 was released installs go backwards and replace later 
version installed packages. I am wondering if this same personality for 
the installer is effecting FC4 to FC5T3 upgrades also. Major libraries 
were involved.

FC5T1 through rawhide, then to FC5T3 install disc bug. (not supported, 
but may happen for FC4 or similar supported paths.



Well fix that in the next (upgrade, update, patch release, service pack).

More information about the fedora-test-list mailing list