F12b won't start X on ThinkPad W700 - works now

Robert G. (Doc) Savage dsavage at peaknet.net
Mon Nov 2 16:42:42 UTC 2009

On Sun, 2009-11-01 at 13:22 -0800, Adam Williamson wrote:
> On Sun, 2009-11-01 at 21:39 +0100, Vedran Miletić wrote:
> > Have you tried "forcing" it to use nouveau (by removing nv or by
> > explicitely specifying nouveau in xorg.conf)? It would be interesting
> > to see what happens.
> > 
> > Aside from that, can you provide output of lspci -v, to see what
> > module is claiming it? Probably nouveau, and that's an explanation why
> > nv fails.
> It is almost certainly nouveau, there's no real need to check. I need to
> know the exact situation in order to figure out whether there's a bug
> and where the bug is.
> lspci -nn output would be useful. Are you _sure_ there's
> no /etc/X11/xorg.conf file ? The only chips that the auto-detect code
> should use nv for are very old ones. Unless NVIDIA have started re-using
> PCI IDs...

Adam & Vedran,

I did a from-scratch 64-bit F12b installation from DVD last night, so I
can't go back and look for anything from that F12a -> F12b upgrade that
didn't work. The good news is that X now works in the fresh install.
There are some other problems I need to document separately.

'lspci -nn'
01:00.0 VGA compatible controller [0300]:nVidia Corporation Device [10de:061e] (rev a2)

'lspci -v'
01:00.0 VGA compatible controller: nVidia Corporation Device 061e (rev a2) (prog if 00 [VGA controller])
	Subsystem: Lenovo Device 2118
	Flags: bus master, fast devsel, latency 0, irq 16
	Memory at cd000000 (32-bit, non-prefetchable) [size=16M]
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Memory at ce000000 (64-bit, non-prefetchable) [size=32M]
	I/O ports at 2000 [size=128]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [60] Power Management version 3
	Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [78] Express Endpoint, MSI 00
	Capabilities: [100] Virtual Channel <?>
	Capabiltiies: [128] Power Budgeting <?>
	Capabilities: [600] Vendor Specific Information <?>
	Kernel driver in use: nouveau
	Kernel modules: nouveau, nvidiafb
No xorg.conf file here. (Note to self: after all the effort I went
through in the old days to learn how to customize xf86.conf, I really
need to pop the hood on this new server and figure out how it works.)


More information about the fedora-test-list mailing list