[fedora-virt] qemu user emulation test package, and is GUEST_BASE broken?

Robert P. J. Day rpjday at crashcourse.ca
Wed Apr 8 12:50:34 UTC 2009

  moving on, i'm continuing to document QEMU on f11 here:


and i have (unsurprisingly) a couple of questions.

  when i first started playing with QEMU a while back, i found the
user emulation test tarball here:


really handy to see what worked and what didn't.  is there any chance
of bundling up something like that and turning it into another fedora
QEMU package?  maybe "qemu-user-tests" or something like that, if
there are no licensing restrictions?  i think a number of beginners
would find that useful.  (the test script in that tarball,
"qemu-linux-user.sh", could be simplified tremendously, of course.)

  and, more technically, the following attempt to test user emulation
for ARM (and ARMEB) using that test tarball fails thusly (running as a
non-root user):

  $ qemu-arm -L gnemul/qemu-arm arm/ls
  mmap: Permission denied.

apparently, this is because ARM tries to mmap to *very* low memory,
and the /proc/sys/vm/mmap_min_addr file is, by default, set to 65536.
the alleged solution is explained here:


to set the environment variable GUEST_BASE to 65536.  now, that might
have worked once upon a time, but it doesn't seem to work now.  on the
other hand, if you have root access, you can just:

  # echo 0 > /proc/sys/vm/mmap_min_addr

and things suddenly work just fine.  should GUEST_BASE work?  or is
one reduced to needing root access to change that setting on a global
basis?  and once i know the answer, i'll add it to my wiki page.  cuz
that's just the kind of guy i am. :-)


Robert P. J. Day                               Waterloo, Ontario, CANADA

       Linux Consulting, Training and Annoying Kernel Pedantry.


More information about the Fedora-virt mailing list