diskless vs ltsp local apps

Robert Arkiletian robark at gmail.com
Mon Oct 13 03:16:56 UTC 2008

On Sun, Oct 12, 2008 at 7:23 PM, Warren Togami <wtogami at redhat.com> wrote:
> Robert Arkiletian wrote:
>> got firefox installed in chroot
>> I can get it to start (although it takes half a minute to launch) But
>> it's having problems resolving names. I've checked /etc/resolv.conf in
>> the chroot. It's the same as on the server. I also enabled ip
>> forwarding in kernel
>> echo 1 >  /proc/sys/net/ipv4/ip_forward
>> which was off by default. But I still cannot get firefox to load pages
>> running locally
> You need an iptables NAT rule for the ltspbr0 device, not ethX devices.  You
> might also want to run dnsmasq serving only the ltspbr0 interface.

Thanks Warren. Tried both ltspbr0 and eth0 (eth0 is external interface)

iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

fixed the problem. This can also be set through system-config-firewall

Okay next problem.
flash-plugin.i386 was not available through yum in the chroot (but it
is outside the chroot) so I installed flash by
 cp  /usr/lib/mozilla/plugins/libflashplayer.so
and then I installed
in the chroot with yum (which worked)

flash is working on the locally running firefox BUT all youtube videos
stop playing after about 2 seconds AND there is *no* sound. But flash
adverts without sound seem to be working fine.

Robert Arkiletian
Eric Hamber Secondary, Vancouver, Canada
Fl_TeacherTool http://www3.telus.net/public/robark/Fl_TeacherTool/
C++ GUI tutorial http://www3.telus.net/public/robark/

More information about the K12Linux-devel-list mailing list