fl_teachertool port K12Linux

Robert Arkiletian robark at gmail.com
Fri Jun 5 03:51:30 UTC 2009

On Thu, Jun 4, 2009 at 7:28 PM, murrah boswell<otrcomm at isp-systems.net> wrote:
> Anybody know when a port of fl_teachertool to K12Linux is going to be
> available? I have downloaded fl_teachertool-0.70 and followed the manual
> installation steps at
> http://www3.telus.net/public/robark/Fl_TeacherTool/installation.html, but
> still not working.
> I get "No users logged in"
> If I run netstat -t -e -n, I see that my test TC user is connected at
> with group 501 and since at line 1845 in
> fl_teachertool.cxx I see
> getstdout_ss(outss, "LANG=C netstat -t -e -n|grep :6000| grep ESTABLISHED
> |sed -e 's/:/ /g'| sed -e 's/ESTABLISHED/ESTABLISHED /' | awk '{print
> $9,$6}'|sort|uniq", "ERROR: netstat failed");
> the grep statement will always return an empty set and raise the "No users
> logged in" error. I tried changing the entry in fl_teachertool.cxx to grep
> :6001, commented out line 1868 that reads
> dummy.ip= getstdout("getent hosts | grep -w "+dummy.ip+" | awk '{print $2}'
> ","Error: getent failed");
> and recompiled. This did allow fl_teachertool to see my session, but I could
> not connect to it.
> Anybody have any thoughts about this?

Hi Murrah,

Yes. I am planning on fixing things for k12linux. My program was
developed for k12ltsp. See the very recent thread "Remote Client

Robert Arkiletian
Eric Hamber Secondary, Vancouver, Canada

More information about the K12Linux-devel-list mailing list