[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Server Clone



Jim Kronebusch wrote:

I have tried
issuing the grub-install command both running from the CD and when
Chrooted into /tmp/sda2, but I still get the same errors. That is what
make me think the formatting is hosed from Ghost. Also when I go to
install a clean version of WBEL onto the Ghost formatted drives I have a
small amount of free space in the front and back of the drive that I
cannot get rid of unless I initialize the drives from the SCSI bios and
start over, which really makes me think Ghost is hosing things.


The fact that grub-install doesn't recognize your /dev/sda seems strange to me. It makes me think that there is something wrong with the filesystem underneath.

On the rsync topic - when you boot the new server with a knoppix cd - do you see the raid-enabled sda?
If so - have you tried this :
1. partition disk with fdisk - setting up partitions the same as the original machine except home is smaller IIRC ...
2. mkfs.ext3 /dev/sda1
3. mkfs.ext3 /dev/sda2
4. swapon /dev/sdX (not sure you need this step)
5. mkdir /tmp/newroot
6. mkdir /tmp/newroot/boot
7. mount /dev/sda2 /tmp/newroot
8. mount /dev/sda1 /tmp/newroot/boot
9. run the rsync command which syncs original /boot to /tmp/newroot/boot
10. run the rsync command which syncs original / to /tmp/newroot
11. chroot /tmp/newroot
12. grub-install /dev/sda
13. reboot


No idea if that would work but it would be the steps I would try ...

good luck :)

pantz

--
Before you criticize someone, walk a mile in their shoes ...
That way when you do criticize them, you're a mile away and you have their shoes!



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]