[K12OSN] lilo config? MBR hosery? boot issues...

anthony baldwin anthonybaldwin at snet.net
Fri May 14 22:49:01 UTC 2004

Les Mikesell wrote:
> On Fri, 2004-05-14 at 17:02, anthony baldwin wrote:
>>> If you hadn't had the boot floppy
>>>you could still recover by using the install cd and entering
>>>'linux rescue' at the boot prompt, then following the instructions
>>>to 'chroot /mnt/sysinstall' later.  That would have you running
>>>with your drives mounted so the /sbin/lilo would work.
>>Thanks for the quick reply.
>>Maybe I should try the cd rescue?
> No, it doesn't fix anything, it just boots you so you
> run completely from the CD and if it can find an installation
> on the hard disk it tries to mount it so you can chroot there.
> Then commands you execute work more or less like they would
> if you had booted normally.  You are still pretty much on your
> own to figure out the right commands.
>>[root at localhost tony]# /sbin/lilo
>>Fatal: open /boot/message: No such file or directory
>>[root at localhost tony]#
> Do you have a /boot partition?  Is there a file named
> message?  I think this is supposed to be a graphic but
> it should be optional.  If that is all that is wrong,
> you can remove the 'message=/boot/message' line from
> /etc/lilo.conf and try to run /sbin/lilo again.

I tried to create an empty /boot/message since there was nothing there with
touch /boot/message
I thought that running /sbin/lilo would alter the file as needed, 
perhaps.  But when I tried to run /sbin/lilo again, I got
[root at localhost tony]# /sbin/lilo
Fatal: Empty map section
I will try to comment out the line as you suggest.
I did, btw, try to rescue with CD and run /sbin/lilo from there, but, as 
you indicate, that was fruitless...

Anthony Baldwin
Freedom to Learn!

GED$/L/P/FA d? s: a C++ L++ W++ N++ K- w--- M+ PS++
PE-- Y+ PGP- t+ tv-- b++(b++++) D? G e++++ h++ r--- y?

More information about the K12OSN mailing list