[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] [OT]router howto



First, we've got to see if your routing parameters in your DHCP scope are right. Have your DHCP clients ping the router that is upstream from your GNU/Linux router; this will be your ISP's router, probably a Cisco or Juniper router of some sort. I'm assuming here that your GNU/Linux router is directly connected to your ISP with nothing else (cable modem, DSL router, other firewall, etc.) in between. If that doesn't work, then make sure that your GNU/Linux router can get to it; if it can't, then nothing will be able to. If it can, though, then check your IP Masquerading rules. This assumes you're using RFC 1918 "private" IP addresses; if not, then don't worry about masquerading rules.

Once all that's working, then we've got to try connectivity past your ISP's router. Try pinging an IP address instead of a domain name. A good one is 198.6.1.2, which is one of UUNet's main DNS servers. If you can, then the problem probably is the DNS server parameters in your DHCP scope.

My guess is that, once you get connectivity to your ISP's router from your clients, then going to the Internet will also work.

--TP

Dale Sykora wrote:

This is slightly off topic, but I thought I'd ask as this list is usually very helpful. I am having trouble trying to setup a generic fc4 or centos4 into a network router. eth0 goes out to the internet and eth1 goes to the internal network. Internal systems can get an ip from the server and can ping the server, but they cannot ping anything on the internet such as yahoo.com. I tried enabling ip_forward in /etc/sysctl and tried comparing settings with a SME server, but I can't figure out what I am missing. Any suggestions on what I should check next?

Thanks,

Dale

_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]