[K12OSN] Remote NX and SMBMOUNT

John Lucas mrjohnlucas at gmail.com
Sun Dec 10 18:45:47 UTC 2006

I don't have the answer to your query, but I do have a possible alternative if 
you can't get NX to work for you the way you wish.

There is a "freeware" program for Windows named "CoreFTP LE" (Light Edition) 
that can use SSH/SFTP and makes an acceptable remote file manager. I can drag 
and drop between Windows Explorer to CoreFTP. 

Working Linux to Linux, I use Konqueror (the KDE file manager and web browser) 
which also uses the "sftp://" protocol. I have also used Nautilus, but it 
doesn't default to the user's home directory (must give explicit path), the 
way KDE does (Nautilus will start in the "/" directory if you don't tell it 
otherwise). Konqueror suits me better anyway, since I use KDE as my primary 

I know it would be aesthetically satisfying to get the exact same experience 
remotely as locally using NX, but using sftp clients works, is secure, and 
has the advantage of not requiring a full desktop session is all you need is 
to tranfer some files. So, I run NX for interactive needs (like admin tasks), 
and another window with Konqueror side-by-side for file xfer and file 
management tasks. Consider this a possible "plan B".

On Sunday 10 December 2006 12:37, Paul Humphreys wrote:
> Dear Colleagues,
> I am able to use NX on my Windows-XP computer at home, to connect over the
> internet to the LTSP Server at my place of work.
> All works very well, and I am happy, except...
> ...when I enable the local NX-client's 'services' tab intended for file
> sharing, I get the following server-response:
> ---
> Info: Share: '//DEVXP/paul' failed to mount: /usr/bin/nxnode: line 959:
> smbmount: command not found
> ---
> Has anyone come across a resolution to this one please?
> In mitigation, I have done *some* online research which suggests that the
> command 'smbmount' is no longer fashionable (albeit currently called from
> /usr/bin/nxnode). I confirm I cannot find the file 'smbmount' on the server
> --- however, it appears to me that all available SMB and SAMBA packages are
> installed. [OR -- in which other package would I expect to find 'sbmmount'
> should this be the remedy?]
> And I have tried the alternative 'mount -t cifs //DEVXP/paul /mnt/paultemp'
> without success.
> I'm hoping with NX to be able to drag-and-drop files between my remote
> computer and the server. Just as I can when I am on the LAN.
> Interestingly, cut-and-paste of plain text works fine --- even without
> explicitly sharing. But it's the equivalent for whole files I am after.
> Any pointers most appreciated.
> With many thanks (and Season's greetings to all)
> Paul
> Paul Humphreys
> (still a relatively newbie user, delighted with LTSP, resident in Oxford
> UK)

        "History doesn't repeat itself; at best it rhymes."
                        - Mark Twain

| John Lucas                          MrJohnLucas at gmail.com               |
| St. Thomas, VI 00802                http://mrjohnlucas.googlepages.com/ |
| 18.3°N, 65°W                        AST (UTC-4)                         |

More information about the K12OSN mailing list