[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] fl_teachertool monitor- control blank screen



On 12/16/06, Barry Cisna <brcisna eazylivin net> wrote:
Hello All,

Fresh install of K12LTSP v5. I've used fl_teachertool since first version.
I tried enabling the Monitor/Control part of fl_teachertool[0.34] per the
/usr/share/docs/fl_teachertool/install.txt. I changed the path for the
"sudoers" from the documented /usr/local/bin/Fl_TeacherTool to
usr/sbin/fl_teachertool to coincide with the rpm install of
fl_teachertool.
Problem: When i try and either Monitor or Control a client machine (as
root) from server or another workstation i get a blank/black screeen on
TightVNC.
I'm not sure how to troubleshoot this,as far as doing a "ps
aux>something",,or whatever. I dont see any weird errors in system
messages either.
Do i need to restart the server for the changes i added in the
/opt/ltsp/i386/etc/lts.conf
X4_MODULE_02 = vnc
( I have not restarted server since this update.)
also i did remeber to :
/usr/bin/vncpasswd
cp -R -p /root/.vnc /opt/ltsp/i386/root/

ROBARK to the rescue please,,,:)

I'm back. I have been in a power outage since Thursday night. You
realize how dependent you are on electricity when you don't have it.

Okay Barry here is the standard message I send to people having
trouble with fl_teachertool. If it still doesn't work let us know.

Below is the specific instructions to enable the control/monitor
features of fl_TT for K12LTSP 5.0 or later. These are not done by
default for two reasons. One is that passwords are different for
everbody. Two is that the x11vnc module is not required by people who
are not using fl_TT. I'm not sure exactly how much resources loading
the x11vnc module takes up on the client but why enable it if people
are not going to use it. Therefore, Eric left it as an option. It's a
one line edit.

1) Edit the file /opt/ltsp/i386/etc/lts.conf and uncomment (remove the
"#") from the following line:

              X4_MODULE_02 = vnc

2) Now you'll have to make a password for the vnc-session. Run this
command as root user:

             /usr/bin/vncpasswd

3) Again as root user copy the password file into the ltsp-tree

            cp -R -p /root/.vnc /opt/ltsp/i386/root/

4) Important: Reboot your clients

If you wish teachers who do not have root password to run fl_TT, then
follow the instructions below.

Setting Up Fl_TeacherTool to run with sudo:

 Step 1
 Create a group for teachers using "system-config-users".
 For example 'teachers'. Then add that group to all the users who
 you wish to run fl_teachertool.

 Step 2
 become root with
 $su -
 Then run "visudo". It's a special editor for the sudoers file.
 Add the following line to the end of the file using vi editing techniques

 %teachers  ALL=NOPASSWD:/usr/sbin/fl_teachertool

 make sure that it's not the last line
 (in other words: don't forget to hit enter)
 If you don't know vi then just goto the last line and hit the
 letter "i" for (insert) then type the above line, hit enter, then hit
 the escape key. Now type    :wq     (hit enter) this saves and exits.

 Step 3
 If your fellow teachers are not comfortable typing "sudo
/usr/sbin/fl_teachertool" then add an alias in file .bashrc (notice it
starts with a period) in the home directory of the people who will run
the program like this

 # User specific aliases and functions
 alias teach='sudo /usr/sbin/fl_teachertool'

 Then they only have to type "teach"

 or alternatively put a launcher icon with the command
 sudo /usr/sbin/fl_teachertool
 on their desktop





Thanks,

Barry Cisna

_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>



--
Robert Arkiletian
Eric Hamber Secondary, Vancouver, Canada
Fl_TeacherTool http://www3.telus.net/public/robark/Fl_TeacherTool/
C++ GUI tutorial http://www3.telus.net/public/robark/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]