[K12OSN] nxclient won't run, missing charsets--solved

Petre Scheie petre at maltzen.net
Thu Jan 19 14:33:38 UTC 2006

Answering my own post, it seems the nxclient included in the freenx package is broken. 
I downloaded the nxclient RPM from nomachine.com and installed that and it works just 
fine.  For the record, the article on the Fedora News website at 
http://fedoranews.org/contributors/rick_stout/freenx/ is really helpful.

Is anyone using freenx to give outside access to school computer systems?  That is, is 
anyone running a server with freenx and allowing students/teachers to connect from home 
by using nxclient on their home computers?  Since the traffic is all encrypted over port 
22, I'd think it would be reasonably safe.

Petre Scheie wrote:
> I installed freenx via yum yesterday on a K12LTSP 4.4.1 server.  The 
> nxserver works like a champ (mostly), but when I try to start the 
> nxclient via the command line, to connect to another server, I get an 
> error about 'missing charsets' and that it can't load a fontset.  A 
> dialog box also pops up, but there's no text in it (perhaps because of 
> the missing charsets?).  Googling, I found one post that says doing an 
> 'export LANG=C' gets rid of the errors on the command line, but the 
> empty dialog box still pops up and nxclient still doesn't start. I also 
> tried starting nxclient on a Centos 4 box and got the same empty dialog 
> box but no errors and it would not run; so it seems like it might be a 
> Red Hat thing.  Interestingly, nxclient works just fine on my old 
> K12LTSP 3.0.1 (RH8) box.  Is anyone else seeing this?  Better still, 
> anyone got a workaround?
> Petre
> _______________________________________________
> K12OSN mailing list
> K12OSN at redhat.com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>

More information about the K12OSN mailing list