[K12OSN] Re: New amer.com switch troubles

gKw-X gkw-x at shaw.ca
Tue Jan 3 22:03:21 UTC 2006


I emailed recently about this problem and I want to bring it up again. I 
have a 1gig switch from amer.com and a 1gig intel nic in my server, but 
for some reason the connection between the server and the switch will 
not go over 100meg speed...

I have tried a couple commands to tell it to re-negotiate, and to tell 
it to go at 1000meg/full duplex, but it always ends up back at 
100meg/full duplex. This is one of the commands I tried:

ethtool -s eth0 duplex full speed 1000

I have had several people suggest the cabling, I will give that another 
try, but it's a long drive to go in and I would like to have some other 
options when I do. What commands should I be running to verify the 
connection, and to change it? Is there any config anywhere that might 
tell it to use 100meg only? Or is it guaranteed to be a problem outside 
of the server?

I've heard certain kernels have trouble with 1gig speed. I don't know 
what version I have, but I downloaded k12ltsp in early August. Someone 
specifically mentioned that kernel version "2.6.11" and earlier has 
troubles with GB ethernet? Has anyone else ever had similar troubles or 
did it just magically work?

Also, I am pretty sure the cable is cat5e, and cable from the same spool 
is used between the swithes, and that connection reports 1000meg speed 
on the switch, so the cable should be fine, correct? Unless that one 
cable was badly crimped or by sheer bad luck has a flaw. Someone 
suggested I need cat6 cable, is this true?

Thanks for your input!

More information about the K12OSN mailing list