[K12OSN] tight vnc connection to ltsp client refused (111 error)

Jesse McDonnell jessemcdonnell at comcast.net
Mon May 22 00:36:07 UTC 2006

On Sun, 21 May 2006 14:51:35 -0700
"Robert Arkiletian" <robark at gmail.com> wrote:

> > > >
> > > > Everything seems to work except for keyboard input when in Control mode, mouse input is fine. For example, I began this reply from the terminal, launched Fl_teachertool as root from the server and took control of the terminal. I added a few words to the reply, then launched a command line Gnome terminal. At that point, I lost keyboard input for all applications on the terminal desktop and it doesn't return when I close the Gnome terminal.
> > >
> > > Have you noticed this behavior on previous versions of k12ltsp (4.x).
> > > Wondering if it only occurs with the new vnc.so on k12ltsp 5.0?
> >
> > Robert,
> >
> > This is the first time I tried the Control and Monitor feature. I installed TeacherTool before on earlier k12ltsp setups to see how it would work but since I run K12LTSP at home I didn't have any reason to worry about monitor and control.
> >
> > Something that I noticed after posting yesterday, Broadcast also won't accept keyboard input. I click Broadcast on the server and the gdm login box launches but it won't accept keyboard input.
> Try clicking in the login box before you start typing. I know this
> sounds obvious but sometimes I forget to set the keyboard focus into
> the box before I type and get what you are describing. Unlike a
> regular gdm login, keyboard focus is not autmatically given to the
> login box when broadcasting.


Tried Broadcast mode, had keyboard focus and it still wouldn't accept input even though there was a flashing curser in the login box. Closed the TeacherTool session and tried again, and yes, this time it worked.

I tried to see if starting and restarting would work in the Control mode also, but now it wouldn't accept any keyboard input, period.  You'll remember that initially I had keyboard input in Control mode and it vanished after I open a terminal window. Seems like that was coincidence.


More information about the K12OSN mailing list