[K12OSN] yum problems on dialup

Eric Harrison eharrison at mail.mesd.k12.or.us
Tue May 30 18:29:14 UTC 2006

Gavin Chester wrote:
> On Tue, 2006-05-30 at 10:04 -0700, Eric Harrison wrote:
>> Have you tried increasing the timeout value? It defaults to 30 seconds,
>> which may be too short for dial-up. Try editing /etc/yum.conf and add
>> something like:
>> 	timeout=180
>> -Eric
> Eric, brilliant as usual! :-)  I was going to ask "how do I increase the
> timeout" but you answered it for me anyway.  That timeout setting has
> done the trick on this slow dialup connection and serves as a 'heads up'
> to anyone else similarly suffering.
> Now, I just have to tackle that issue of the XML file not parsing
> correctly when I use the repo 'extras'.  Perhaps the first thing I
> should do is restore the original repo file by removing my pasted-in
> Australian mirror for that repo.  See how I go :-) 

I'm guessing that the XML parsing issue will be resolved by increasing
the timeout.
The parsing error is probably due to the fact that you downloaded PART
of the file before it timed out.


>> Gavin Chester wrote:
>>> On Tue, 2006-05-30 at 15:53 +0800, Gavin Chester wrote:
>>> -snip-
>>>> I have a stock-standard 4.4.1 K12LTSP install, and using the supplied
>>>> yum conf files and repos.  I've had to disable the K12 repo entirely
>>>> because it never works for me, and when trying to run yum to upgrade or
>>>> install new apps more often than not the other repos also time out and
>>>> the operation fails with messages such as:
>>>> ------------------------------
>>>> Trying other mirror.
>>>> primary.xml.gz            100% |=========================| 312 kB
>>>> 01:14
>>>> http://mirror.hiwaay.net/redhat/fedora/linux/extras/4/i386/repodata/primary.xml.gz: [Errno 4] Socket Error: timed out
>>>> Trying other mirror
>>>> ------------------------------
>>>> 	.. and so, and so on for all repos until no more mirrors left.
>>>> 	Sometimes I get a 404 error, such as:
>>> -snip-
>>>> Cannot open/read repomd.xml file for repository: base
>>>> Error importing repomd.xml from base: Error: could not parse
>>>> file //var/cache/yum/base/repomd.xml
>>>> --------------------------------- 
>>>> Can anyone shed any light on this?  Or, is dialup always going to be a
>>>> problem with my new install?  I had occasional trouble with my old yum
>>>> setup, but never as consistently bad as this.  So far I've only managed
>>>> a couple of new apps installed with yum.  
>>> I looked into this some more and followed the directions given at the
>>> foot of this page:
>>> http://fedoraproject.org/wiki/Extras/Mirrors
>>> to add a local mirrors for fedora-extras, at least.
>>> Now I consistently get an error that yum failed to parse the XML file:
>>> -------------------
>>> cannot open/read repomd.xml file for repository: extras
>>> Error importing repomd.xml from extras: Error: could not parse
>>> file //var/cache/yum/extras/repomd.xml
>>> -------------------
>>> I even tried reverting to using apt, but of course it doesn't come setup
>>> with decent repos anymore.  When I did configure the livna repo, apt
>>> just wanted to remove packages to be able to add new ones.  I am NOT
>>> going down that path again, so forget it, apt :-(
>>> Gavin.

More information about the K12OSN mailing list