[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Full system file access from terminals??



This may be a little oversimplified, but...

/etc/exports contains the files required for the terminal to get up and
running, and to "see" the server.

Once the terminal can see the server, all the programs run on the
server and display on the terminal.  So it is normal for the terminals
to have full access to the server's file system.  Note that this is not
insecure, because you still have all the Linux file system permissions
keeping regular users out of the stuff that they shouldn't have access
to.  This is by default, and you don't need to change any permissions in
order to acheive this.  Regular users can see some, but not all system
files, and they can't modify any of them.

-Rob

On Tue, Mar 20, 2007 at 04:07:11PM -0700, xmechanic wrote:
> <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
> <html>
> <head>
>   <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
>   <title></title>
> </head>
> <body bgcolor="#ffffcc" text="#663300">
> <font face="Arial">Hi,<br>
> I run a small computer service that services a local K-12 school
> district and I've been experimenting with K12OS with the hopes of
> making a valid presentation to the school to get them interested in
> moving to a thin client type environment.&nbsp; I first downloaded version
> 6.0 and installed it on a test machine here with dual NICs, and no
> matter how I configured it, I could never get my client(s) to boot. The
> server would hand off the IP address to the terminal from DHCP, and
> then it would hang while trying to load the kernel. I checked my
> /etc/dhcpd.conf, ltsp.conf, /etc/exports, and everything else I could
> think of, to no avail. I finally started checking forums and found that
> several people have had client boot problems with 6.0. So I downloaded
> and installed Ver. 5.0 and copied over the sample /etc/dhcpd.conf file
> and voila! The terminal(s) boot perfectly. Now for problem "B". It
> seems the terminal users have access to the servers complete file
> system! According to my /etc/exports file, this shouldn't be so. I
> think somehow the terminal is loading the server system rather than the
> filesystem exported from /opt/ltsp/i386. What tipped me off was the
> fact that when I log off a user on the terminal, I get an x-server
> error on the server screen and have to hit Ctrl-alt-F7 to get my screen
> back. Anyone have any ideas? I really like this system now that the
> terminals actually boot from it. A 733mhz. Dell desktop with 256mb of
> RAM takes about 35 seconds to go from power off to a login screen and
> another 12 seconds to the desktop. That would certainly be quicker with
> a real boot ROM instead of a boot floppy. If I can get the exports
> thing worked out and get it to boot from the correct filesystem, I'll
> be a happy camper. Any and all input greatly appreciated.&nbsp; I've been
> about 4 days on this now and I'm running out of ideas. :-p<br>
> <br>
> Dave Land<br>
> Land Computer Service<br>
> </font>
> <pre class="moz-signature" cols="72">-- 
> TARDIS Express, When it absolutely, positively *has* to arrive before you mail it.
> 
> </pre>
> </body>
> </html>
> 

> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]