[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] k12ltsp el5 etherboot problem



Barry R Cisna wrote:
> Hello List,
>
> I done a clean install on two of our schools FCx servers to k12ltsp el5.
> Most all the clients we have now are pxe. They boot fine. Just for kicks
> today i tried a couple of the Dell Optiplex,not sure number? that has
> onboard 3com 3c905x nics. 

I use Optiplex GX1's.  These have the built-in 3c905, and they do
PXE-boot quite nicely.  Matter of fact, I think Jim McQuillan and
someone else were selling reconditioned Optiplex GX1's as LTSP thin
clients.  The catch is that they do need to have a recent BIOS in them,
because some of the earlier BIOSes for these boxes did have buggy
PXE-boot code in them.  I found that out the hard way during a K12LTSP demo.

> These two that I tested I had installed
> etherboot to the Hd, not that ,that makes any diff, and on the two I
> tested I get " no ip address found". Like the dhcp server is nowhere to
> be found? These machines have worked fine on every version of Fedora
> Core -x. I am not sure what version the eb_to_hd installs on the HD of
> etherboot? As I said all of the PXE boot machines works fine. I have
> iptables stopped. The system logs show nothing on account of "no ip
> address found".Maybe I missed the boat on possibly a
> different/directory/path for etherboot on el5? Googled this but no
> cigar.
> Any ideas?

How'd you install Etherboot to the HD?  The way I do it is by doing "cat
MyEtherbootImage > /dev/hda".  Note that I didn't specify a partition,
but rather the HD itself.

Also, it's possible that the Optiplex is configured to PXE-boot, and
further, that it has one of the early buggy BIOSes in it.  Best to turn
that off.  IIRC, it's called "Network boot".

--TP


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]