[K12OSN] ltsp-build-client - command not found

Brian Fristensky bfristen at shaw.ca
Sun Nov 2 21:32:21 UTC 2008

> On my F9 system, ltsp-build-client is in /usr/sbin/, and rpm shows that it
> was installed via the ltsp-server package.  Since you have to be root to do
> all these steps, did you, by chance, use 'su' to become root instead of 'su
> -' ? The former doesn't set root's environment, including the $PATH, meaning
> it won't find all the various tools in /sbin, /usr/sbin, etc.
> Peter

Yes, that was the problem. When I ran it as /usr/sbin/ltsp-build-client
the command worked, correctly installing the files in /opt/ltsp.

The instructions didn't specifically say to run the command
as sudo, and I always find it convenient to have a terminal window
open as root when I am doing sysadmin stuff. It is actually a bit
surprising to me that su would not set root's $PATH,
but I there are probably good reasons for that.


Brian Fristensky
971 Somerville Avenue
Winnipeg MB R3T 1B4 CANADA
bfristen at shaw.ca

More information about the K12OSN mailing list