[Libguestfs] [PATCH 0/3] rename icat API into download_inode

Matteo Cafasso noxdafox at gmail.com
Wed Mar 30 19:18:07 UTC 2016

The command name is a bit confusing because it's similar to "cat" but act as "donwload". Therefore I am renaming it with a more clear name.

At the same go I cleaned up a bit the code following the standards and improved the API documentation.

This patch is ready for review.
Code available at:


Matteo Cafasso (3):
  Rename icat command in download_inode
  Improve download_inode documentation string.
  Code cleanup in daemon/sleuthkit.c

 daemon/sleuthkit.c               | 50 ++++++++++++++++++++-----------------
 generator/actions.ml             | 10 +++++---
 tests/tsk/Makefile.am            |  2 +-
 tests/tsk/test-download-inode.sh | 53 ++++++++++++++++++++++++++++++++++++++++
 tests/tsk/test-icat.sh           | 53 ----------------------------------------
 5 files changed, 88 insertions(+), 80 deletions(-)
 create mode 100755 tests/tsk/test-download-inode.sh
 delete mode 100755 tests/tsk/test-icat.sh


More information about the Libguestfs mailing list