[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] [ovirt-users] OVA import of FC21 VM hangs during virt-v2v conversion?



Hi,

On Wed, November 16, 2016 5:15 pm, Richard W.M. Jones wrote:
> On Wed, Nov 16, 2016 at 05:09:56PM -0500, Derek Atkins wrote:
>
> I'll try to reproduce the issue here, but you can also do
> the following command directly on the guest disk image if you
> want to test something:
>
>   time LIBGUESTFS_BACKEND=direct guestfish --ro -a fc21-64.qcow2 -i
> selinux-relabel /etc/selinux/targeted/contexts/files/file_contexts /
> force:true
>
> As long as you make sure you use the '--ro' flag, this will not make
> any changes to the disk image.

The OVA has a .vmdk file inside it.  I have no idea where ovirt put the
.qcow2 file.  I suppose I would need to track it down through the VM GUID?

Can I run this command on the disk image of a running VM that's already
been imported?  Or... better, can I run it on a .vmdk file?  Or, worst
case, is there a way to convert the .vmdk to a .qcow2?

> For me that command only takes ~15 seconds to run on a Fedora 21 disk
> image with minimal (@Core) packages installed.  I'm using a
> RHEL 7.3 host.

So noted.  Like I said, I can supply you the ova file if you think it
would help.  It's only 1.7GB  ;)

Thanks,

-derek

>
> Rich.
>
> --
> Richard Jones, Virtualization Group, Red Hat
> http://people.redhat.com/~rjones
> Read my programming and virtualization blog: http://rwmj.wordpress.com
> virt-df lists disk usage of guests without needing to install any
> software inside the virtual machine.  Supports Linux and Windows.
> http://people.redhat.com/~rjones/virt-df/
>


-- 
       Derek Atkins                 617-623-3745
       derek ihtfp com             www.ihtfp.com
       Computer and Internet Security Consultant


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]